您的位置:首页 > 大数据 > 人工智能

poj2527——Polynomial Remains(多项式相除)

2016-03-31 14:02 507 查看
Description


Given the polynomial 
a(x) = an xn + ... + a1 x + a0,

compute the remainder r(x) when a(x) is divided by xk+1.
Input

The input consists of a number of cases. The first line of each case specifies the two integers n and k (0 <= n, k <= 10000). The next n+1 integers give the coefficients of a(x), starting from a0 and ending with an. The input is terminated if n = k = -1.
Output

For each case, output the coefficients of the remainder on one line, starting from the constant coefficient r0. If the remainder is 0, print only the constant coefficient. Otherwise, print only the first d+1 coefficients for a remainder of degree d. Separate
the coefficients by a single space. 

You may assume that the coefficients of the remainder can be represented by 32-bit integers. 

Sample Input
5 2
6 3 3 2 0 1
5 2
0 0 3 2 0 1
4 1
1 4 1 1 1
6 3
2 3 -3 4 1 0 1
1 0
5 1
0 0
7
3 5
1 2 3 4
-1 -1

Sample Output
3 2
-3 -1
-2
-1 2 -3
0
0
1 2 3 4


多项式相除,由于除数为x^k+1,因此商的当前项为anx^(n-k),使得余数多项式数组中的a
=0,a[n-k]=a[n-k]-a
;然后调整a数组的长度

#include <iostream>
#include <string>
#include <algorithm>
#include <cstdio>
using namespace std;
int a[10010],n; //a保存多项式以及改变之后的多项式
int main()
{
int k,i;
scanf("%d%d",&n,&k);
while(n!=-1&&k!=-1)
{
for(i=0; i<=n; ++i)
scanf("%d",&a[i]);
for(i=n; i>=k; i--)
{
if(a[i]==0)
continue;
a[i-k]=a[i-k]-a[i];
a[i]=0;
}
int t=n;
while(a[t]==0&&t>0) //调整多项式数组长度,直到最高项的不为0
t--;
for(i=0; i<t; ++i)
if(a[i]!=0)
printf("%d ",a[i]);
printf("%d\n",a[t]);
scanf("%d%d",&n,&k);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: