您的位置:首页 > 其它

HDU2192建房子

2016-03-29 17:01 162 查看

MagicBuilding

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1976 Accepted Submission(s): 887



[align=left]Problem Description[/align]
As the increase of population, the living space for people is becoming smaller and smaller. In MagicStar the problem is much worse. Dr. Mathematica is trying to save land by clustering buildings and then we call the set of buildings
MagicBuilding. Now we can treat the buildings as a square of size d, and the height doesn't matter. Buildings of d1,d2,d3....dn can be clustered into one MagicBuilding if they satisfy di != dj(i != j).

Given a series of buildings size , you need to calculate the minimal numbers of MagicBuildings that can be made. Note that one building can also be considered as a MagicBuilding.

Suppose there are five buildings : 1, 2, 2, 3, 3. We make three MagicBuildings (1,3), (2,3), (2) .And we can also make two MagicBuilding :(1,2,3), (2,3). There is at least two MagicBuildings obviously.

[align=left]Input[/align]
The first line of the input is a single number t, indicating the number of test cases.

Each test case starts by n (1≤n≤10^4) in a line indicating the number of buildings. Next n positive numbers (less than 2^31) will be the size of the buildings.

[align=left]Output[/align]
For each test case , output a number perline, meaning the minimal number of the MagicBuilding that can be made.

[align=left]Sample Input[/align]

2
1
2
5
1 2 2 3 3


[align=left]Sample Output[/align]

1
2大体是建房子,间距为n,如果相同的高度,就合在一起#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <set>
using namespace std;

int main()
{
int n,a[10001],i,j,m,sum;
scanf("%d",&n);

while(n--)
{
scanf("%d",&m);

for(i=0; i<m; i++)
{
scanf("%d",&a[i]);
}
sum=0;
for(i=0; i<m; i++)
{
int e=1;
for(j=i+1; j<=m; j++)
{
if(a[i]==a[j])
e++;
if(e>sum)
sum=e;
}
}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: