您的位置:首页 > Web前端 > JavaScript

pojsupermark

2016-04-05 16:46 519 查看
Supermarket

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 9103Accepted: 3891
Description

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time
for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is
Profit(Sell)=Σx∈Sellpx. An optimal selling schedule is a schedule with a maximum profit.

For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts
at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80.



Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products.

Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product.
White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input
4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2
5 20  50 10


Sample Output
80
185
题意:超市有n样东西要卖出去,每dp个花费dd单位时间可以卖出去赚得最大利润,现要求计算如何赚得最大利润。解题:将最大的先卖,卖不完的放到前一天一起卖,其中利润大的优先卖,这样一直卖到最小的时候,就能获得最大利润。因为期限小的不可能在大时间时候卖出去,而大期限的可以在小的期限时间里卖。建立一个优先队列,大的优先,用sort排序将存放数据p,d的数组ans从大到小排好序。压入队列,使得最大的利润被压出。
#include<cstdio>
#include<iostream>
#include<queue>
#include<algorithm>
using namespace std;
#define N 10005
typedef struct nnn
{
    int p,d;
}node;
typedef struct nn
{
    int p;
    friend bool operator<(struct nn a,struct nn b)//优先队列值从大到小取
    {
        return a.p<b.p;
    }
}INT;
node ans
;
int cmp(node a,node b)//最后期限从大到小排
{
    return a.d>b.d;
}
int solve(int n,int l)
{
    int maxp=0,tl,d,i,maxd;
    priority_queue<INT>q;
    INT pp;
    i=0;
    for(maxd=ans[0].d; maxd>0;maxd--)
    {
        for( ;i<n&&maxd<=ans[i].d; i++)
        {
            pp.p=ans[i].p; q.push(pp);
        }
        tl=0;
        while(!q.empty()&&tl<l)
        {
            pp=q.top(); q.pop();
            maxp+=pp.p; tl++;
        }
    }
    return maxp;
}
int main()
{
    int n,l,i;
  while(scanf("%d",&n)>0)
    {
        for( i=0;i<n;i++)
            scanf("%d%d",&ans[i].p,&ans[i].d);
        if(n==0)
        {
            printf("0\n"); continue;
        }
        sort(ans,ans+n,cmp);
        printf("%d\n",solve(n,1));
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: