您的位置:首页 > 其它

problem-1006 Elevator 解题报告

2016-03-24 20:09 363 查看
Problem Description

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to
move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

 

 

Input

There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

 

 

Output

Print the total time on a single line for each test case. 

 

 

Sample Input

1 2 3 2 3 1 0

 

 

Sample Output

17 41

 

原始楼层是一楼,电梯上升一层为6秒,下降一层是4秒,每次升降停顿时间为5秒,求总花费时间=总共上升的楼层数*6+总共下降的楼层数*4+升降的次数*5

楼层不变另算

ac代码:

</pre><pre name="code" class="cpp">#include<cstdio>
#include<iostream>
#include<cmath>
using namespace std;
int main(){
int n,m,i,a,sum;
while(cin>>n)
{
if(n==0) break;
cin>>m;
if(n==1) {cout<<6*m+5<<endl;continue;}
a=m;
sum=6*m;
for(i=1;i<n;i++)
{
cin>>m;
if(a>m) sum+=4*(a-m);
else sum+=6*(m-a);
a=m;
}
sum=sum+5*n;
cout<<sum<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm