您的位置:首页 > 其它

【bzoj1180】【CROATIAN2009】【OTOCI】【lct】

2016-03-24 18:44 357 查看

Description

给出n个结点以及每个点初始时对应的权值wi。起始时点与点之间没有连边。有3类操作: 1、bridge A B:询问结点A与结点B是否连通。如果是则输出“no”。否则输出“yes”,并且在结点A和结点B之间连一条无向边。 2、penguins A X:将结点A对应的权值wA修改为X。 3、excursion A B:如果结点A和结点B不连通,则输出“impossible”。否则输出结点A到结点B的路径上的点对应的权值的和。给出q个操作,要求在线处理所有操作。数据范围:1<=n<=30000,
1<=q<=300000, 0<=wi<=1000。

Input

第一行包含一个整数n(1<=n<=30000),表示节点的数目。第二行包含n个整数,第i个整数表示第i个节点初始时对应的权值。第三行包含一个整数q(1<=n<=300000),表示操作的数目。以下q行,每行包含一个操作,操作的类别见题目描述。任意时刻每个节点对应的权值都是1到1000的整数。

Output

输出所有bridge操作和excursion操作对应的输出,每个一行。

Sample Input

5

4 2 4 5 6

10

excursion 1 1

excursion 1 2

bridge 1 2

excursion 1 2

bridge 3 4

bridge 3 5

excursion 4 5

bridge 1 3

excursion 2 4

excursion 2 5

Sample Output

4

impossible

yes

6

yes

yes

15

yes

15

16

题解:直接用lct即可。

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#define N 300010
using namespace std;
int st
,v
,x,y,c
[2],s
,n,q,fa
,rev
;
char ch[20];
bool isroot(int x){return c[fa[x]][0]!=x&&c[fa[x]][1]!=x;}
void updata(int x){int l=c[x][0],r=c[x][1];s[x]=s[l]+s[r]+v[x];}
void pushdown(int x){
int l=c[x][0],r=c[x][1];
if (rev[x]){rev[l]^=1;rev[r]^=1;rev[x]^=1;swap(c[x][0],c[x][1]);}
}
void rotata(int x){
int l,r,y=fa[x],z=fa[y];
if (c[y][0]==x) l=0;else l=1;r=l^1;
if (!isroot(y)){if (c[z][0]==y) c[z][0]=x;else c[z][1]=x;}
fa[x]=z;fa[y]=x;fa[c[x][r]]=y;
c[y][l]=c[x][r];c[x][r]=y;
updata(y);updata(x);
}
void splay(int x){
int top(0);st[++top]=x;
for (int i=x;!isroot(i);i=fa[i]) st[++top]=fa[i];
for (int i=top;i;i--) pushdown(st[i]);
while(!isroot(x)){
int y=fa[x],z=fa[y];
if (!isroot(y)){
if (c[y][0]==x^c[z][0]==y) rotata(y);
else rotata(x);
}
rotata(x);
}
}
void access(int x){int t(0);while(x){splay(x);c[x][1]=t;t=x;updata(x);x=fa[x];}}
void makeroot(int x){access(x);splay(x);rev[x]^=1;}
void link(int x,int y){makeroot(x);fa[x]=y;}
void cut(int x,int y){makeroot(x);access(y);splay(y);fa[x]=c[y][0]=0;}
void split(int x,int y){makeroot(y);access(x);splay(x);}
int find(int x){access(x);splay(x);int y=x;while (c[y][0]) y=c[y][0];return y;}
int main(){
scanf("%d",&n);
for (int i=1;i<=n;i++){scanf("%d",&v[i]);s[i]=v[i];}
scanf("%d",&q);
for (int i=1;i<=q;i++){
scanf("%s",ch);scanf("%d%d",&x,&y);
if (ch[0]=='b'){
if (find(x)==find(y)) printf("no\n");else printf("yes\n"),link(x,y);
}
if (ch[0]=='p'){splay(x);v[x]=y;updata(x);}
if (ch[0]=='e'){
if (find(x)!=find(y))printf("impossible\n");
else{split(x,y);printf("%d\n",s[x]);}
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: