您的位置:首页 > 其它

POJ-1426-Find The Multiple【BFS】

2016-03-21 22:57 393 查看

1426-Find The Multiple

Time Limit:1000MS     Memory Limit:10000KB


Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2

6

19

0

Sample Output

10

100100100100100100

111111111111111111

题目链接:POJ-1426

题目大意:给出一个数n,求一个数m,只由0和1组成,且是n的倍数(存在多个可任意输出)

题目思路:直接BFS即可。数字大小不会超过19位,用long long可以存下。

G++可过。

以下是代码:

//
//  E.cpp
//  搜索
//
//  Created by pro on 16/3/21.
//  Copyright (c) 2016年 pro. All rights reserved.
//

#include <iostream>
#include <cstdio>
#include <cmath>
#include <vector>
#include <cstring>
#include <algorithm>
#include <string>
#include <set>
#include <functional>
#include <numeric>
#include <sstream>
#include <stack>
#include <map>
#include <queue>
#include<iomanip>
using namespace std;
queue<long long> que;
long long bfs(int n)
{
que.push(1);
while(!que.empty())
{
long long front = que.front();
que.pop();
if (front % n == 0) return front;
que.push(front * 10);
que.push(front * 10 + 1);
}
return 0;
}
int main()
{
int n;
while(cin >> n && n)
{
while (!que.empty()) {  //注意清空
que.pop();
}
cout << bfs(n) << endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  bfs POJ 1426