您的位置:首页 > 其它

Trucking(HDU 2962 最短路+二分搜索)

2016-03-19 15:15 369 查看

Trucking

Time Limit: 20000/10000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2216 Accepted Submission(s): 757


[align=left]Problem Description[/align]
A certain local trucking company would like to transport some goods on a cargo truck from one place to another. It is desirable to transport as much goods as possible each trip. Unfortunately, one cannot always use the roads in the shortest route: some roads may have obstacles (e.g. bridge overpass, tunnels) which limit heights of the goods transported. Therefore, the company would like to transport as much as possible each trip, and then choose the shortest route that can be used to transport that amount.

For the given cargo truck, maximizing the height of the goods transported is equivalent to maximizing the amount of goods transported. For safety reasons, there is a certain height limit for the cargo truck which cannot be exceeded.

[align=left]Input[/align]
The input consists of a number of cases. Each case starts with two integers, separated by a space, on a line. These two integers are the number of cities (C) and the number of roads (R). There are at most 1000 cities, numbered from 1. This is followed by R lines each containing the city numbers of the cities connected by that road, the maximum height allowed on that road, and the length of that road. The maximum height for each road is a positive integer, except that a height of -1 indicates that there is no height limit on that road. The length of each road is a positive integer at most 1000. Every road can be travelled in both directions, and there is at most one road connecting each distinct pair of cities. Finally, the last line of each case consists of the start and end city numbers, as well as the height limit (a positive integer) of the cargo truck. The input terminates when C = R = 0.

[align=left]Output[/align]
For each case, print the case number followed by the maximum height of the cargo truck allowed and the length of the shortest route. Use the format as shown in the sample output. If it is not possible to reach the end city from the start city, print "cannot reach destination" after the case number. Print a blank line between the output of the cases.

[align=left]Sample Input[/align]

5 6
1 2 7 5
1 3 4 2
2 4 -1 10
2 5 2 4
3 4 10 1
4 5 8 5
1 5 10
5 6
1 2 7 5
1 3 4 2
2 4 -1 10
2 5 2 4
3 4 10 1
4 5 8 5
1 5 4
3 1
1 2 -1 100
1 3 10
0 0
0 0

[align=left]Sample Output[/align]

Case 1:
maximum height = 7
length of shortest route = 20

Case 2:
maximum height = 4
length of shortest route = 8

Case 3:
cannot reach destination

题意:给定一个无向图,每条边有长度,通过最大高度两个权值,求解从起点到终点的能通过的最大高度以及在此高度上的最短路径长度

思路:二分搜索,每次进行一次最短路算法Dijkstra,路径更新公式需要添加 map[i][v].h>=p||map[i][v].h==-1

需要注意最后一行不能输出\n PE了两次

#include <cstring>
#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;
#define Max 1005
#define INF 9999999
struct node
{
int len,h;
}map[Max][Max];
bool vis[Max];
int dis[Max];
int c,r;
int s,e,height;

bool Dijkstra(int p)
{
int i,j;
memset(vis,0,sizeof(vis));
for(i=0;i<=c;i++)
dis[i]=INF;
dis[s]=0;
while(true)
{
int v=0;
for(i=1;i<=c;i++)
{
if(!vis[i]&&(v==0||dis[i]<dis[v]))
v=i;
}
if(v==0)
break;
vis[v]=1;
//cout<<v<<endl;
//    cout<<"3 "<<dis[3]<<endl;
for(i=1;i<=c;i++)
{
if(vis[i]==0&&(map[i][v].h>=p||map[i][v].h==-1)&&(dis[v]+map[i][v].len<dis[i]))
dis[i]=dis[v]+map[i][v].len;
}
}
return dis[e]!=INF;
}

int main()
{
int i,j;
int a,b;
int t=1;
freopen("in.txt","r",stdin);
while(scanf("%d%d",&c,&r))
{
if(c==0&&r==0)
break;
for(i=0;i<=c;i++)
for(j=0;j<=c;j++)
{
map[i][j].h=0;
map[i][j].len=INF;
}
for(i=0;i<r;i++)
{
scanf("%d%d",&a,&b);
scanf("%d%d",&map[a][b].h,&map[a][b].len);
map[b][a].h=map[a][b].h;
map[b][a].len=map[a][b].len;
}
scanf("%d%d%d",&s,&e,&height);
int lb=0,rb=height+1,mid,ans,length=INF;
while(rb-lb>1)
{
mid=(rb+lb)/2;
if(Dijkstra(mid))
{
length=dis[e];
ans=mid;
lb=mid;
}
else
rb=mid;
}
if(t!=1)
printf("\n");
if(length==INF)
printf("Case %d:\ncannot reach destination\n",t++);
else
{
printf("Case %d:\n",t++);
printf("maximum height = %d\n",ans);
printf("length of shortest route = %d\n",length);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: