您的位置:首页 > 其它

Intervals

2016-03-18 19:50 134 查看


Intervals

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 3623    Accepted Submission(s): 1329


Problem Description

You are given n closed, integer intervals [ai, bi] and n integers c1, ..., cn.

Write a program that:

> reads the number of intervals, their endpoints and integers c1, ..., cn from the standard input,

> computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i = 1, 2, ..., n,

> writes the answer to the standard output

 

Input

The first line of the input contains an integer n (1 <= n <= 50 000) - the number of intervals. The following n lines describe the intervals. The i+1-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai
<= bi <= 50 000 and 1 <= ci <= bi - ai + 1.

Process to the end of file.

 

Output

The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i = 1, 2, ..., n.

 

Sample Input

5
3 7 3
8 10 3
6 8 1
1 3 1
10 11 1

 

Sample Output

6

 

Author

1384

 

Recommend

Eddy   |   We have carefully selected several similar problems for you:  1529 1531 1548 1534 1317 

 

Statistic | Submit | Discuss | Note
这个题刚开始题都看不懂,完全不知道要算的是什么,后来讲过之后才理解了题意,然后也不会写,看过学长的程序后,现在才算是真的懂了这个题了,spfa中用到了先进先出的队列,最开始的时候只把源点压入队列中,并且用一个数组来存从源点到其他每个点的距离,最初设置的距离都是INF,源点到自己的距离是0,然后取出队首的点计算到其他每个点的距离是否小于当前的距离,是则更新,并判断这个点是否在队列中,如果不在则把他压入队尾,如果一个点被压入队列超过了n次则说明存在有负值的环。因为这个题没有说有环的情况,所以可以不用判环。

#include<cstdio>
#include<iostream>
#include<queue>
#include<cstring>
#include<algorithm>
#define N 51000
#define inf 1e9

using namespace std;
int num,p
,n;
struct node
{
int en,len,next;
}edg[N*10];
void add(int st,int en,int len)
{
edg[num].en=en;
edg[num].len=len;
edg[num].next=p[st]; //该节点的前一个位置
p[st]=num++; //该节点当前的位置
}
queue<int>que;
bool inque
;
int dis
;
void spfa(int st,int en)
{
for(int i=0;i<=en;i++)
{
dis[i]=-inf;
inque[i]=false;
}
que.push(st);
dis[st]=0;
inque[st]=true;
while(que.size())
{
int x=que.front();
que.pop();
inque[x]=false;
for(int i=p[x];i!=-1;i=edg[i].next)
{
int y=edg[i].en;
if(dis[x]+edg[i].len>dis[y])
{
dis[y]=dis[x]+edg[i].len;
if(!inque[y])
{
que.push(y);
inque[y]=true;
}
}
}
}
}
int main()
{
while(~scanf("%d",&n))
{
num=0;
memset(p,-1,sizeof(p));
int st=inf,en=-1;
for(int i=1;i<=n;i++)
{
int a,b,c;
scanf("%d%d%d",&a,&b,&c);
add(a,b+1,c);
st=min(st,a);
en=max(en,b+1);
}
for(int i=st;i<=en;i++)
{
add(i,i-1,-1);
add(i-1,i,0);
}
spfa(st,en);
printf("%d\n",dis[en]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: