您的位置:首页 > 其它

e-模拟

2016-03-17 19:08 337 查看
E - 模拟
Time Limit:2000MS Memory Limit:65536KB 64bit IO Format:%lld
& %llu
Submit Status Practice ZOJ
3878

Description

Edward, a poor copy typist, is a user of the Dvorak Layout. But now he has only a QWERTY Keyboard with a broken Caps
Lock key, so Edward never presses the broken Caps Lock key. Luckily, all the
other keys on the QWERTY keyboard work well. Every day, he has a lot of documents to type. Thus he needs a converter to translate QWERTY into Dvorak. Can you help him?

The QWERTY Layout and the Dvorak Layout are in the following:


The QWERTY Layout

The Dvorak Layout
Input

A QWERTY document Edward typed. The document has no more than 100 kibibytes. And there are no invalid characters in the document.

Output

The Dvorak document.

Sample Input

Jgw Gqm Andpw a H.soav Patsfk f;doe
Nfk Gq.d slpt a X,dokt vdtnsaohe
Kjd yspps,glu pgld; aod yso kd;kgluZ
1234567890
`~!@#$%^&*()}"']_+-=ZQqWEwe{[\|
ANIHDYf.,bt/
ABCDEFuvwxyz


Sample Output

Hi, I'm Abel, a Dvorak Layout user.
But I've only a Qwerty keyboard.
The following lines are for testing:
1234567890
`~!@#$%^&*()+_-={}[]:"'<>,.?/\|
ABCDEFuvwxyz
AXJE>Ugk,qf;


PS:模拟题,水题来的

代码:

#include<iostream>
#include<stdio.h>
#include<string>
using namespace std;

int main()
{
string s1 = "_-+=QqWwEeRrTtYyUuIiOoPp{[}]SsDdFfGgHhJjKkLl:;\"'ZzXxCcVvBbNnMm<,>.?/";
string s2 = "{[}]\"'<,>.PpYyFfGgCcRrLl?/+=OoEeUuIiDdHhTtNnSs_-:;QqJjKkXxBbMmWwVvZz";
char c;
while (~scanf("%c", &c))
{
int is = true;
for (int i = 0; i < s1.length(); ++i)
{
if (c == s1[i])
{
is = false;
cout << s2[i];
break;
}
}
if (is)
{
cout << c;
}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: