您的位置:首页 > 其它

poj 1328 Radar Installation 【贪心】【区间选点问题】

2016-03-16 08:43 561 查看
Radar Installation

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 54798Accepted: 12352
Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the
sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write
a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.



Figure A Sample Input of Radar Installations

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing
two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1


题意:就是找最少的站,来覆盖所有的点。

思路:我们能够以点来做半径为d的圆,与x轴的相交,假设不相交那么肯定完不成任务,反之就转化成了区间选点问题。

代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
using namespace std;
#define M 1005

struct node {
double st, en;
}s[M];

int cmp(node a, node b){
if(a.en == b.en) return a.st > b.st;
return a.en<b.en;
}

int main(){
int n, v = 1; double d;
while(scanf("%d%lf", &n, &d), n||d){
int i, j;
double a, b;
int flag = 0;
for(i = 0; i < n; i ++){
scanf("%lf%lf", &a, &b);
if(b>d) flag = 1;
if(flag == 0){
s[i].en = a+sqrt(d*d-b*b);
s[i].st = a-sqrt(d*d-b*b);
//printf("%lf %lf %d..\n", s[i].st, s[i].en, i);
}
//	scanf("%lf%lf", &s[i].st, &s[i].en);
}
printf("Case %d: ", v++);
if(flag){
printf("-1\n"); continue;
}
sort(s, s+n, cmp);
int ans = 1;
double maxr = s[0].en;
i = 1, j = 0;
while(i < n){
if(s[i].st <= s[j].en){
//if(maxr < s[i].en) maxr = s[i].en;
++i;
}
else {
//if(j == i-1)
j = i;
++ans;
//	maxr = s[i].en;
}
}
printf("%d\n", ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: