您的位置:首页 > 其它

【hdu2199】Can you solve this equation?——二分

2016-03-13 22:40 399 查看
题目:


Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 15110 Accepted Submission(s): 6739



Problem Description

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;

Now please try your lucky.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

Sample Input

2
100
-4


Sample Output

1.6152
No solution!


Author

Redow

描述:求方程的解

题解:二分裸题

代码:

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
using namespace std;
const double eps = 1e-10;
double f(double x)
{
return 8.0 * pow(x,4) + 7 * pow(x,3) + 2 * pow(x,2) + 3 * x + 6;
}
int main()
{
//freopen("input.txt", "r", stdin);
int T;
scanf("%d", &T);
while (T--)
{
double Y;
scanf("%lf", &Y);
double l = 0.0;
double r = 100.0;
if (f(l) > Y || f(r) < Y)
{
printf("No solution!\n");
continue;
}
while (r - l > eps)
{
double mid = (l + r) / 2;
if (f(mid) > Y)
r = mid;
else
l = mid;
}
printf("%.4lf\n", r);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: