您的位置:首页 > 其它

HDU 5640 King's Cake

2016-03-13 15:49 288 查看

King's Cake



Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 233 Accepted Submission(s): 190


[align=left]Problem Description[/align]
It is the king's birthday before the military parade . The ministers prepared a rectangle cake of sizen×m(1≤n,m≤10000)
. The king plans to cut the cake himself. But he has a strange habit of cutting cakes. Each time, he will cut the rectangle cake into two pieces, one of which should be a square cake.. Since he loves squares , he will cut the biggest square cake. He will continue
to do that until all the pieces are square. Now can you tell him how many pieces he can get when he finishes.

[align=left]Input[/align]
The first line contains a number
T(T≤1000),
the number of the testcases.

For each testcase, the first line and the only line contains two positive numbersn,m(1≤n,m≤10000).

[align=left]Output[/align]
For each testcase, print a single number as the answer.

[align=left]Sample Input[/align]

2
2 3
2 5


[align=left]Sample Output[/align]

3
4

hint:
For the first testcase you can divide the into one cake of $2\times2$ , 2 cakes of $1\times 1$

[code]#include<iostream>
using namespace std;

int main(){
int t,i,j,n,m,s,k;
while(cin>>t){
for(i=0;i<t;i++){
cin>>n>>m;
k=0;
s=n*m;
while(n!=m){
if(n>m){
n-=m;
}
else{
m-=n;
}
k++;
}
cout<<k+1<<endl;
}
}
return 0;
}


[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: