您的位置:首页 > 大数据 > 人工智能

HDU1021Fibonacci Again

2016-03-13 10:51 357 查看


Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 49607 Accepted Submission(s): 23534



Problem Description

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output

Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.

Sample Input

0
1
2
3
4
5


Sample Output

no
no
yes
no
no
no


题目大意:
它新定义了一个斐波那契数列为F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2);
输入有多行,每一行有一个正整数 n(n<1000000);
输出:
Print the word "yes" if 3 divide evenly into F(n).
就是说F
能够被3整除,也就是F
对3去余为0;

思路:
如果有正整数 a, b, c, d, x; 假如: c=a+b, x=c%d ,那么可以知道 x=(a+b)%d; 易推知,x=(a%d+b%d)%d;

ps:参考同余定理

给出AC代码:
#include<iostream>
using namespace std;
int F[1000005];
int main()
{
F[0] = 7 % 3, F[1] = 11 % 3;
for (int i = 2; i < 1000005; i++)
F[i] = (F[i - 1] + F[i - 2]) % 3;
int n;
while (cin >> n)
{
if (F
== 0)cout << "yes" << endl;
else cout << "no" << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: