您的位置:首页 > 编程语言 > Go语言

hdu Dragon Balls 3635【并查集】

2016-03-12 16:23 459 查看


Dragon Balls

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 5155    Accepted Submission(s): 1930


Problem Description

Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together. 



His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical
strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls. 

Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the
ball has been transported so far.

 

Input

The first line of the input is a single positive integer T(0 < T <= 100). 

For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).

Each of the following Q lines contains either a fact or a question as the follow format:

  T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.

  Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)

 

Output

For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.

Sample Input

2

3 3

T 1 2

T 3 2

Q 2

3 4

T 1 2

Q 1

T 1 3

Q 1

 

Sample Output

Case 1:

2 3 0

Case 2:

2 2 1

3 3 2

 

 

Author

possessor WC

题目大意:要找龙珠啊找龙珠,找龙珠啊,龙珠~~~~~~~~~~~~~~

操作1:T A,B把球A所在的city中所有龙珠转到B球所在城市中。

操作2:Q A,要求输出A球所在城市,这个城市有多少球,A球运送了多少次。

思路:并查集、

针对操作1:把球A所在的city中的所有龙珠转到B中,我们需要先找到A球所在的城市,然后把这个城市的元素数全部加到B上。

void merge(int a,int b)//b
{
int A,B;
A=find(a);//找到A所在city
B=find(b);//找到B所在city
if(A!=B)
{
f[A]=B;//连接
j[B]+=j[A];//把A所在城市中所有球都转到B中。
j[A]=0;//注意:是转移,所以这里要变成0、
}
}


针对操作2:输出A球所在的城市,直接find(a),找到a球所在城市。刚刚也处理了转移元素个数的操作,所以第二个输出直接输出J[find(A)]就可以了。第三个是要输出A转移次数,其实就是要找带有A的连接次数,也其实就是找A一共有多少父节点,有一个父节点就说明搬运了一次。

完整AC代码:

#include<stdio.h>
#include<string.h>
using namespace std;
int f[10002];
int j[10002];
int find(int a)
{
int r=a;
while(f[r]!=r)
r=f[r];
return r;
}
int find2(int a)
{
int cont=0;
int r=a;
while(f[r]!=r)
{
r=f[r];
cont++;
}
return cont;
}
void merge(int a,int b)//b
{
int A,B;
A=find(a);
B=find(b);
if(A!=B)
{
f[A]=B;
j[B]+=j[A];
j[A]=0;
}
}
int main()
{
int t;
int kase=0;
scanf("%d",&t);
while(t--)
{
int n,m;
scanf("%d%d",&n,&m);
for(int i=1;i<=n;i++)
{
f[i]=i;
j[i]=1;
}
printf("Case %d:\n",++kase);
while(m--)
{
char s[5];
scanf("%s",s);
if(s[0]=='T')
{
int A,B;
scanf("%d%d",&A,&B);
merge(A,B);
}
if(s[0]=='Q')
{
int A;
scanf("%d",&A);
printf("%d %d %d\n",find(A),j[find(A)],find2(A));
}
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdu 3635 杭电 3635