您的位置:首页 > 其它

Phone List (POJ_3630) 静态字典树 + 模板题

2016-03-09 21:03 465 查看
Phone List

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 26484 Accepted: 7982
Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let's say the phone catalogue listed these numbers:

Emergency 911
Alice 97 625 999
Bob 91 12 54 26
In this case, it's not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob's phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone
number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output "YES" if the list is consistent, or "NO" otherwise.

Sample Input
2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output
NO
YES


题目大意:判断给出的数字序列,互不为前缀。

解题思路:与HDU_1671完全相同,不过poj如果用动态建树的话,会TLE,所以有用静态建树的方法来做这题。

代码如下:


#include"iostream"
#include"cstdio"
#include"cstring"
using namespace std;
const int maxn = 10;
struct node{
node *next[maxn];
int flag;
};
int Count;
node root; //定义根节点
node memory[800000];
void init(int cnt){
for(int i = 0;i < maxn;i ++){
memory[cnt].next[i] = NULL;
memory[cnt].flag = 0;
}
}
//构建字典树
bool creat(char *str){
bool f1 = false,f2 = true;
int len = strlen(str);
node *p = &root;
for(int i = 0,id = 0;i < len;i ++){
for(int j = 0;j < maxn;j ++){ //自身为前缀
if(p -> flag == 1) f2 = false;
}
id = str[i] - '0';
if(p -> next[id] == NULL){
f1 = true; //自身不为前缀
Count ++;
init(Count);
p -> next[id] = &memory[Count];
}
p = p -> next[id];
}
p -> flag = 1;
return f1&&f2;
}
//释放内存
int main(){
int T,n,f,tf;
char str[15];
scanf("%d",&T);
while(T--){
Count = 0;
scanf("%d",&n);
tf = true;
for(int i = 0;i < n;i ++){
scanf("%s",str);
f = creat(str);
if(f == false) tf = false;
}
if(tf) printf("YES\n");
else printf("NO\n");
for(int i = 0;i < maxn;i ++){
root.next[i] = NULL;
}
root.flag = 0;
}
return 0;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  字典树 静态