您的位置:首页 > 其它

POJ 3070 Fibonacci

2016-03-07 16:45 435 查看
Fibonacci

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11996 Accepted: 8516
Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of
the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …
An alternative formula for the Fibonacci sequence is


.
Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input
0
9
999999999
1000000000
-1

Sample Output
0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by


.
Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:


.

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
const int maxn = 5;
const int MOD = 10000;

struct Matrix
{
int mat[maxn][maxn];
Matrix() //构造函数
{
memset(mat, 0, sizeof(mat));
}

Matrix operator * (Matrix A) //重载运算符*
{
Matrix res;
for (int i = 0; i < 2; i++) //矩阵乘法
{
for (int j = 0; j < 2; j++)
{
for (int k = 0; k < 2; k++)
res.mat[i][j] = (res.mat[i][j] + (mat[i][k] * A.mat[k][j]) % MOD) % MOD;
}
}
return res;
}
};
//快速求矩阵A^n
Matrix pow_mul(Matrix A, int n)
{
Matrix res;
//一个矩阵的0次方为主对角线全为1,其他全为0的矩阵
for (int i = 0; i < maxn; i++) res.mat[i][i] = 1;
while (n)
{
if (n & 1) res = res * A; //若n为奇数
A = A * A;
n >>= 1; //n = n / 2
}
return res;
}

int main()
{
int n;
while (~scanf("%d", &n) && n != -1)
{
Matrix A;
A.mat[0][0] = A.mat[0][1] = A.mat[1][0] = 1;
A = pow_mul(A, n);
cout << A.mat[0][1] << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm 矩阵快速幂