您的位置:首页 > 其它

HDU 1907 John (尼姆博弈)

2016-03-06 18:35 316 查看
Problem Description

Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please note that each player
has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box.

Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.

Input

The first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M colors in a box. Next line
will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color.

Constraints:

1 <= T <= 474,

1 <= N <= 47,

1 <= Ai <= 4747

Output

Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.

Sample Input

2

3

3 5 1

1

1

Sample Output

John

Brother

尼姆博弈,当每堆巧克力数为1时要进行判断,,,

以下AC代码:

#include<stdio.h>
int main()
{
int t,n,a[50];
int i;
int sum;
int flag;
scanf("%d",&t);
while(t--)
{
sum=0;
flag=0;
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
if(a[i]>1)
flag=1;     //当数目为1时需要特判
sum^=a[i];
}
if(flag)
{
if(sum)
printf("John\n");
else
printf("Brother\n");
}
else
{
if(n%2)
printf("Brother\n");
else
printf("John\n");
}
}
return 0;
}


尼姆
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: