您的位置:首页 > 其它

HDOJ 1220-Cube【数学推理】

2016-03-05 13:48 417 查看

Cube

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 1721 Accepted Submission(s): 1366

[align=left]Problem Description[/align]
Cowl is good at solving math problems. One day a friend asked him such a question: You are given a cube whose edge length is N, it is cut by the planes that was paralleled to its side planes into N * N * N unit cubes. Two unit cubes
may have no common points or two common points or four common points. Your job is to calculate how many pairs of unit cubes that have no more than two common points.

Process to the end of file.

[align=left]Input[/align]
There will be many test cases. Each test case will only give the edge length N of a cube in one line. N is a positive integer(1<=N<=30).

[align=left]Output[/align]
For each test case, you should output the number of pairs that was described above in one line.

[align=left]Sample Input[/align]

1
2
3


[align=left]Sample Output[/align]

0
16
297

HintHint
The results will not exceed int type.


[align=left]Author[/align]
Gao Bo

[align=left]Source[/align]
杭州电子科技大学第三届程序设计大赛
解题思路:
题目大意就是将一个大的正方体,切成一个一个的单位正方体,问这些正方体中有多少对(注意是对:也就是两个)是公共顶点小于两个的。
我们知道从这些单位正方体中找出两个的情况是多少n*n*n*(n*n*n-1)/2,又因为公共顶点只可能是0
1 2 4,所以我们找出公共点是4的减去对数就行了。
#include<stdio.h>
#include<string.h>
#include<math.h>
using namespace std;
int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
if(n==1)
{
printf("0\n");
continue;
}
printf("%d\n",n*n*n*(n*n*n-1)/2-3*n*n*(n-1));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: