您的位置:首页 > 其它

PAT (Advanced Level) Practise 1025 PAT Ranking (25)

2016-03-05 13:26 351 查看


1025. PAT Ranking (25)

时间限制

200 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your
job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then
K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.
Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

结构体排序,模拟排名系统
#include<cstdio>
#include<string>
#include<cstring>
#include<vector>
#include<iostream>
#include<queue>
#include<map>
#include<algorithm>
using namespace std;
typedef long long LL;
const int INF = 0x7FFFFFFF;
const int maxn = 1e5 + 10;
int n, m, tot;

struct point
{
	string s;
	int rank, local, localrank, score;
	bool operator<(const point&a) const
	{
		return score == a.score ? s < a.s : score > a.score;
	}
}a[maxn];

int main()
{
	scanf("%d", &n);
	for (int i = 1; i <= n; i++)
	{
		scanf("%d", &m);
		for (int j = 0; j < m; j++, tot++) cin >> a[tot].s >> a[tot].score, a[tot].local = i;
		sort(a + tot - m, a + tot);
		for (int j = tot - m; j < tot; j++)
		{
			if (j>tot - m&&a[j].score == a[j - 1].score) a[j].localrank = a[j - 1].localrank;
			else a[j].localrank = j - tot + m + 1;
		}
	}
	sort(a, a + tot);
	cout << tot << endl;
	for (int i = 0; i < tot; i++)
	{
		if (i&&a[i].score == a[i - 1].score) a[i].rank = a[i - 1].rank;
		else a[i].rank = i + 1;
		cout << a[i].s;
		printf(" %d %d %d\n", a[i].rank, a[i].local, a[i].localrank);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: