您的位置:首页 > 其它

hdu1570(水题)

2016-03-05 09:43 232 查看

A C

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4710 Accepted Submission(s): 3023



[align=left]Problem Description[/align]
Are you excited when you see the title "AC" ? If the answer is YES , AC it ;

You must learn these two combination formulas in the school . If you have forgotten it , see the picture.



Now I will give you n and m , and your task is to calculate the answer .

[align=left]Input[/align]
In the first line , there is a integer T indicates the number of test cases.

Then T cases follows in the T lines.

Each case contains a character 'A' or 'C', two integers represent n and m. (1<=n,m<=10)

[align=left]Output[/align]
For each case , if the character is 'A' , calculate A(m,n),and if the character is 'C' , calculate C(m,n).

And print the answer in a single line.

[align=left]Sample Input[/align]

2
A 10 10
C 4 2


[align=left]Sample Output[/align]

3628800
6


[align=left]Author[/align]
linle

[align=left]Source[/align]
HDU 2007-1 Programming Contest

#include<stdio.h>
int F(int a)
{
int sum=1;
for(int i=1;i<=a;i++)
sum*=i;
return sum;
}
int A(int m,int n){
return F(n)/F(n-m);
}
int C(int m,int n){
return A(m,n)/F(m);
}

int main()
{
char ch;
int t,m,n;
scanf("%d",&t);
while(t--)
{
getchar();
scanf("%c%d%d",&ch,&n,&m);
if(ch=='A')
printf("%d\n",A(m,n));
else
printf("%d\n",C(m,n));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: