您的位置:首页 > 大数据 > 人工智能

【HDU 2457】 【POJ 3691】 DNA repair AC自动机+DP;

2016-03-01 16:22 531 查看
DNA repair

Time Limit: 5000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1939 Accepted Submission(s): 1049

Problem Description

Biologists finally invent techniques of repairing DNA that contains segments causing kinds of inherited diseases. For the sake of simplicity, a DNA is represented as a string containing characters ‘A’, ‘G’ , ‘C’ and ‘T’. The repairing techniques are simply to change some characters to eliminate all segments causing diseases. For example, we can repair a DNA “AAGCAG” to “AGGCAC” to eliminate the initial causing disease segments “AAG”, “AGC” and “CAG” by changing two characters. Note that the repaired DNA can still contain only characters ‘A’, ‘G’, ‘C’ and ‘T’.

You are to help the biologists to repair a DNA by changing least number of characters.

Input

The input consists of multiple test cases. Each test case starts with a line containing one integers N (1 ≤ N ≤ 50), which is the number of DNA segments causing inherited diseases.

The following N lines gives N non-empty strings of length not greater than 20 containing only characters in “AGCT”, which are the DNA segments causing inherited disease.

The last line of the test case is a non-empty string of length not greater than 1000 containing only characters in “AGCT”, which is the DNA to be repaired.

The last test case is followed by a line containing one zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) followed by the

number of characters which need to be changed. If it’s impossible to repair the given DNA, print -1.

Sample Input

2

AAA

AAG

AAAG

2

A

TG

TGAATG

4

A

G

C

T

AGT

0

Sample Output

Case 1: 1

Case 2: 4

Case 3: -1

Source

题意:给你50–个字符串,让你找最小修改次数;

SOLUSION:

1.首先想到搜索 4^n,如图:


但如果病毒没有包含的,可剪支!;

即在AC——auto中的nex(可压缩);

2.病毒FLAG可标记在TRIE树末,多串—》 AC-auto;

flag的性质 : 如果nex【i】 有病毒-》i有病毒;

3.DP:dp[i][j] 在i长度时,到j节点(0多用)的最优解;

dp[i][j] = min(dp[i][j], dp[i-1][nNext] + szText[i-1] != k);



#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;
int n,m;
int flag[21*51];
int nex[21*51];
int ans;
struct node{
int ch[4];
void init()
{
for(int i=0;i<4;i++)
ch[i]=0;
}
}t[21*51];
char s[1005];
int dp[1005][1005];
int tot=0;
int MAX=1000005;
int get(char a)
{
if(a=='A') return 0;
if(a=='T') return 1;
if(a=='C') return 2;
if(a=='G') return 3;
}
inline void insert(char s[])
{
int now=0;
for(int i=0;s[i];i++)
{
if(!t[now].ch[get(s[i])])
{
t[now].ch[get(s[i])]=++tot;
t[tot].init(),nex[tot]=0,flag[tot]=0;
}
now=t[now].ch[get(s[i])];
}
flag[now]=1;

}
queue<int> q;
inline void get_nex()
{
int now=0;
for(int i=0;i<4;i++)
if(t[0].ch[i]) q.push(t[0].ch[i]);
while(!q.empty())
{
now=q.front();
int next=nex[now];
q.pop();
for(int i=0;i<4;i++)
{
if(t[now].ch[i])
{
nex[t[now].ch[i]]=t[next].ch[i];
if(flag[t[next].ch[i]]) flag[t[now].ch[i]]=1;
q.push(t[now].ch[i]);
}
else t[now].ch[i]=t[next].ch[i];
}
}

}
inline void DP()
{

int len=strlen(s);
for(int i=0;i<=len;i++)
for(int j=0;j<=tot;j++)
dp[i][j]=MAX;
dp[0][0]=0;
for(int i=0;i<len;i++)
for(int j=0;j<=tot;j++)
{
if(dp[i][j]==MAX) continue;
for(int k=0;k<4;k++)
{
int tt=t[j].ch[k];
if(flag[tt]) continue;
dp[i+1][tt]=min(dp[i+1][tt],dp[i][j]+(get(s[i+1-1])!=k));
}
}
ans=MAX;
for(int i=0;i<=tot;i++) ans=min(ans,dp[len][i]);
//  cout<<dp[1][1]<<endl;

}
int main()
{
int T=0;
while(scanf("%d",&n))
{
if(n==0) return 0;
tot=0;
t[tot].init();
for(int i=1;i<=n;i++)
{

scanf("%s",s);
insert(s);
}
get_nex();

scanf("%s",s);
DP();
printf("Case %d: ",++T);
if(ans==MAX) printf("-1\n");
else printf("%d\n",ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: