您的位置:首页 > 其它

POJ2782(贪心)

2016-02-25 18:34 411 查看
Description

A set of n 1-dimensional items have to be packed in identical bins. All bins have exactly the same length l and each item i has length li<=l . We look for a minimal number of bins q such that

each bin contains at most 2 items,

each item is packed in one of the q bins,

the sum of the lengths of the items packed in a bin does not exceed l .

You are requested, given the integer values n , l , l1 , …, ln , to compute the optimal number of bins q .

Input

The first line of the input contains the number of items n (1<=n<=10 5) . The second line contains one integer that corresponds to the bin length l<=10000 . We then have n lines containing one integer value that represents the length of the items.

Output

Your program has to write the minimal number of bins required to pack all items.

Sample Input

10

80

70

15

30

35

10

80

20

35

10

30

Sample Output

6

贪心题,把长度依次从大到小排列,先把最大最小装一盒试试,如果可以,就把n-1,相当于把小盒和大盒装到了一起,否则大盒就只能单独装,依次装,直到装完。

#include <iostream>
#include <cstdio>
#include <algorithm>

using namespace std;
const int maxn = 100000 + 5;

int cmp(int a, int b)
{
return a > b;
}

int main()
{
int n, l, li[maxn] = {0}, nu = 0;
cin >> n >> l;
for (int i = 0; i < n; i++) {
cin >> li[i];
}
sort (li, li + n, cmp);
for (int i = 0; i < n; i++) {
nu++;
if (li[i] + li[n - 1] <= l) n--;
}
cout << nu << endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: