您的位置:首页 > 其它

UVA679

2016-03-28 23:36 344 查看
Description

A number of K balls are dropped one by one from the root of a fully binary tree structure FBT. Each

time the ball being dropped first visits a non-terminal node. It then keeps moving down, either follows

the path of the left subtree, or follows the path of the right subtree, until it stops at one of the leaf

nodes of FBT. To determine a ball’s moving direction a flag is set up in every non-terminal node with

two values, either false or true. Initially, all of the flags are false. When visiting a non-terminal node

if the flag’s current value at this node is false, then the ball will first switch this flag’s value, i.e., from

the false to the true, and then follow the left subtree of this node to keep moving down. Otherwise,

it will also switch this flag’s value, i.e., from the true to the false, but will follow the right subtree of

this node to keep moving down. Furthermore, all nodes of FBT are sequentially numbered, starting at

1 with nodes on depth 1, and then those on depth 2, and so on. Nodes on any depth are numbered

from left to right.

For example, Fig. 1 represents a fully binary tree of maximum depth 4 with the node numbers 1,

2, 3, …, 15. Since all of the flags are initially set to be false, the first ball being dropped will switch

flag’s values at node 1, node 2, and node 4 before it finally stops at position 8. The second ball being

dropped will switch flag’s values at node 1, node 3, and node 6, and stop at position 12. Obviously,

the third ball being dropped will switch flag’s values at node 1, node 2, and node 5 before it stops at

position 10.

Now consider a number of test cases where two values will be given for each test. The first value is

D, the maximum depth of FBT, and the second one is I, the I-th ball being dropped. You may assume

the value of I will not exceed the total number of leaf nodes for the given FBT.

Please write a program to determine the stop position P for each test case.

For each test cases the range of two parameters D and I is as below:

2 ≤ D ≤ 20, and 1 ≤ I ≤ 524288.

Input

Contains l + 2 lines.

Line 1 l the number of test cases

Line 2 D1 I1 test case #1, two decimal numbers that are separated by one blank



Line k + 1 Dk Ik test case #k

Line l + 1 Dl Il test case #l

Line l + 2 -1 a constant ‘-1’ representing the end of the input file

Output

Contains l lines.

Line 1 the stop position P for the test case #1



Line k the stop position P for the test case #k



Line l the stop position P for the test case #l

Sample Input

5

4 2

3 4

10 1

2 2

8 128

-1

Sample Output

12

7

512

3

255

这道题的题意是,有一个二叉树,深度为D,初始时所有结点的flag均为false。一个小球从根结点往下落,如果所落节点的flag为false,那小球就会落向左孩子,否则会落向右孩子,小球所在位置的flag要改变,如果是false就改成true,如果是true就改成false。求第I个小球的落点位置。

这道题不是很难,不过纯模拟就会超时。所以要写算法来优化解决过程。发现,如果小球的I为奇数,那小球会落向左孩子,否则会落向右孩子,每落一层,都把I变换一次,就能知道是落向左孩子还是右孩子。

#include <iostream>
#include <cstring>
#include <cstdio>

using namespace std;

int main()
{
int D, I, t;
#ifndef ONLINE_JUDGE

a536
freopen ("in.txt", "r", stdin);
#endif // ONLINE_JUDGE
cin >> t;
while (t--) {
cin >> D >> I;
int k = 1;
for (int i = 0; i < D - 1; i++) {
if (I % 2) {
k = k * 2;
I = (I + 1) / 2;
} else {
k = k * 2 + 1;
I /= 2;
}
}
cout << k << endl;
}
cin >> t;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: