您的位置:首页 > 其它

poj 1979 Red and Black (简单BFS)

2016-02-19 17:15 357 查看
Red and Black

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 28318 Accepted: 15405
Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 

'#' - a red tile 

'@' - a man on a black tile(appears exactly once in a data set) 

The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output
45
59
6
13

这题只需要使用简单的BFS进行搜索即可

#include <stdio.h>
#include <iostream>
#include <string.h>
#include <math.h>
#include <ctype.h>
#include <algorithm>
#include <map>
#include <math.h>
#include <stack>
#include <queue>
#define Max 25
#define inf 100000000
using namespace std;
char m[Max][Max];
int Mov[4][2] = {{0,1},{1,0},{-1,0},{0,-1}};
bool vis[Max][Max];
int W,H;
int dfs(int x,int y){
int res = 1;
vis[x][y] = true;
for (int i=0; i<4; i++) {
int nx = x+Mov[i][0],ny = y + Mov[i][1];
if (nx>=0&&nx<H&&ny>=0&&ny<W) {
if (!vis[nx][ny]&&m[nx][ny] != '#') {
res += dfs(nx, ny);
}
}
}
// printf("%d\n",res);
return res;    //统计个数
}
int main(){
while (scanf("%d%d",&W,&H)!=EOF&&W+H) {
memset(vis, 0, sizeof(vis));
//getchar();
int xx = -1,yy = -1;
for (int i=0; i<H; i++) {
scanf("%s",m[i]);
for (int j=0; j<W; j++) {
if (m[i][j] == '@') {
xx = i,yy = j;
}
}
}
//        for (int i=0; i<H; i++) {
//            printf("%s\n",m[i]);
//        }
printf("%d\n",dfs(xx, yy));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: