您的位置:首页 > 大数据 > 人工智能

1086. Tree Traversals Again (25)

2016-02-18 00:57 453 查看
An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop();
push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.



Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in
the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:
3 4 2 6 5 1

入栈顺序为前序遍历,出栈顺序为中序遍历,根据前序遍历序列和中序遍历序列确定二叉树.也可以根据输入递归地建树

#include <iostream>
#include <string>
#include <vector>
using namespace std;
int n;
struct node{
int left,right;
node(int l = -1,int r = -1):left(l),right(r){}
};
vector<node> tree;
int inorder(){
string s;int t;
cin>>s;
if(s[1] == 'u'){
cin>>t;
tree[t].left = inorder();
tree[t].right = inorder();
return t;
}else return -1;
}
int kase = 0;
void posterorder(int r){
if(r != -1){
posterorder(tree[r].left);
posterorder(tree[r].right);
if(kase++)cout<<" ";
cout<<r;
}
}
int main(){
cin>>n;
tree.resize(n+1);
posterorder(inorder());
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  pat