您的位置:首页 > 其它

uvaoj-1585:得分

2016-02-12 13:49 281 查看
Score

There is an objective test result such as ``OOXXOXXOOO".
An `O' means a correct answer of a problem and an `X'
means a wrong answer. The score of each problem of this test is calculated by itself and its just previous consecutive `O's
only when the answer is correct. For example, the score of the 10th problem is 3 that is obtained by itself and its two previous consecutive `O's.

Therefore, the score of ``OOXXOXXOOO" is 10 which is calculated
by ``1+2+0+0+1+0+0+1+2+3".

You are to write a program calculating the scores of test results.

Input

Your program is to read from standard input. The input consists ofT
test cases. The number of test casesT is given in the first line of the input. Each test case starts with a line containing
a string composed by `O' and `X'
and the length of the string is more than 0 and less than 80. There is no spaces between `O' and `X'.

Output

Your program is to write to standard output. Print exactly one line for each test case. The line is to contain the score of the test case.

The following shows sample input and output for five test cases.

Sample Input

?

Sample Output

?
题解:水题,什么都不说了,之前做了以后没写博客,所以现在重敲了一下补上;

code:

#include <iostream>

#include <cstring>

using namespace std;

int main()

{

char s[105];

int t;

cin>>t;

while(t--)

{

cin>>s;

int len=strlen(s);

int ans=0;

int n;

for(int i=0; i<len; i++)

{

n=1;

if(s[i]=='O')

{

for(int j=i; ; j++)

{

if(s[j]=='O')

ans+=n;

if(s[j]!='O')

{

i=j;

break;

}

n++;

}

}

}

cout<<ans<<endl;

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: