您的位置:首页 > 其它

uvaoj-12474:大理石在哪里

2016-02-14 22:21 246 查看
Raju and Meena love to play with Marbles. They have got a lot of marbles with numbers written on them. At the beginning, Raju would place the marbles one after another in ascending order of the numbers
written on them. Then Meena would ask Raju to find the first marble with a certain number. She would count 1...2...3. Raju gets one point for correct answer, and Meena gets the point if Raju fails. After some fixed number of trials the game ends and the player
with maximum points wins. Today it's your chance to play as Raju. Being the smart kid, you'd be taking the favor of a computer. But don't underestimate Meena, she had written a program to keep track how much time you're taking to give all the answers. So now
you have to write a program, which will help you in your role as Raju.

Input

There can be multiple test cases. Total no of test cases is less than 65. Each test case consists begins with 2 integers:N
the number of marbles and Q the number of queries Mina would make. The nextN
lines would contain the numbers written on theN marbles. These marble numbers will not come
in any particular order. FollowingQ lines will have
Q queries. Be assured, none of the input numbers are greater than 10000 and none of them are
negative.

Input is terminated by a test case whereN
= 0 andQ = 0.

Output

For each test case output the serial number of the case.

For each of the queries, print one line of output. The format of this line will depend upon whether or not the query number is written upon any of the marbles. The two different formats are described
below:

`x found aty',
if the first marble with numberx was found at position
y. Positions are numbered1,
2,..., N.
`x not found',
if the marble with numberx is not present.

Look at the output for sample input for details.

Sample Input

4 1
2
3
5
1
5
5 2
1
3
3
3
1
2
3
0 0


Sample Output

CASE# 1:
5 found at 4
CASE# 2:
2 not found
3 found at 3


题解:题不难,主要是c++STL的运用,今天没发博客,总感觉怪怪的,正好新学到了STL,来mark下;

code:

#include <iostream>

#include <algorithm>

using namespace std;

int main()

{

int num_q,num_n;

int a[10005];

int times=0;

while(cin>>num_n>>num_q&&num_n)

{

cout<<"CASE# "<<++times<<':'<<endl;

for(int i=0; i<num_n; i++)

cin>>a[i];

sort(a,a+num_n);

int ans;

int x;

while(num_q--)

{

cin>>x;

ans=lower_bound(a,a+num_n,x)-a;

if(a[ans]==x) cout<<x<<" found at "<<ans+1<<endl;//注意要加一哦,因为数组空间是从零开始的,而大理石却是从一开始数的;

else cout<<x<<" not found"<<endl;

}

}

return 0;

}

笔记:sort函数,可以自己编写cmp函数来控制,也可以利用cmp对结构体排序:

code:

struct Time

{

int a;

int b;

}

bool compare(Time A,Time B)

{

return A.b<B.b;

}

情人节快乐!~
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: