您的位置:首页 > 其它

HDU——1058Humble Numbers(找规律)

2016-02-09 12:52 375 查看

Humble Numbers

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 21853 Accepted Submission(s): 9553



[align=left]Problem Description[/align]
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence

[align=left]Input[/align]
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

[align=left]Output[/align]
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.

[align=left]Sample Input[/align]

1
2
3
4
11
12
13
21
22
23
100
1000
5842
0


[align=left]Sample Output[/align]

The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.


#include<iostream>
#include<set>
using namespace std;
typedef long long LL;
LL er=1,san=1,wu=1,qi=1;
LL minn(const LL &a,const LL &b,const LL &c,const LL &d)
{
LL t=a;
if(b<t)
t=b;
if(c<t)
t=c;
if(d<t)
t=d;
//下面都要用if而非else-if 出现重复的数时才可以多个数均被++
if(t==a)
er++;
if(t==b)
san++;
if(t==c)
wu++;
if(t==d)
qi++;
return t;
}
int main(void)
{
LL i;
LL list[5900]={1,1};
for (i=2; i<5900; i++)
{
list[i]=minn(2*list[er],3*list[san],5*list[wu],7*list[qi]);
}
int n;
while (cin>>n&&n)
{
if(n%10==1&&n%100!=11)
printf("The %dst humble number is %lld.\n",n,list
);
else if(n%10==2&&n%100!=12)
printf("The %dnd humble number is %lld.\n",n,list
);
else if(n%10==3&&n%100!=13)
printf("The %drd humble number is %lld.\n",n,list
);
else
printf("The %dth humble number is %lld.\n",n,list
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: