您的位置:首页 > 大数据 > 人工智能

HDU 1022 Train Problem I

2016-02-08 11:58 459 查看
    题目:HDU-1022

    题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1022

    题目:


Train Problem I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 28476    Accepted Submission(s): 10829


Problem Description

As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one
railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train
B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the
trains can get out in an order O2.







 

Input

The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample
Input.

 

Output

The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of
the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.

 

Sample Input

3 123 321
3 123 312

 

Sample Output

Yes.
in
in
in
out
out
out
FINISH
No.
FINISH

    这道题也是挺水的一道题,用STL自带的栈模拟一下很容易就过了。

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<math.h>
#include<stack>
using namespace std;
const int maxn=10005;
int main(){
int n;
char in[maxn],out[maxn];
int ans[maxn];
while(cin>>n){
for(int i=0;i<n;i++)
cin>>in[i];
for(int i=0;i<n;i++)
cin>>out[i];                 //分别输入 入栈、出栈序列
stack<char> S;                       //定义栈
int count=0,j=0;                     //y用ans[count]存储路径,入栈存为0,出栈存为1,以便于打印答案
for(int i=0;i<n;i++){
S.push(in[i]);               //入栈
ans[count++]=0;              //存路径
while(S.top()==out[j] && j<=i){  //判断是否出栈
S.pop();               //出栈
ans[count++]=1;        //存储路径
j++;
if(S.empty()) break;   //如果栈为空直接跳出
}
}
if(S.empty()){                         //如果最后栈空说明所有元素成功出栈则此出栈序列合理
cout<<"Yes."<<endl;
for(int i=0;i<2*n;i++)         //打印路径
if(ans[i]==0)
cout<<"in"<<endl;
else
cout<<"out"<<endl;
}
else
cout<<"No."<<endl;
cout<<"FINISH"<<endl;
}
return 0;
}
    啦啦啦~好好学习,天天向上~新年快乐~
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: