您的位置:首页 > 其它

zoj 1221 Risk【最短路 3种方法】

2016-02-05 20:31 323 查看
Risk

Time Limit: 2 Seconds Memory Limit: 65536 KB

Risk is a board game in which several opposing players attempt to conquer the world. The gameboard consists of a world map broken up into hypothetical countries. During a player's
turn, armies stationed in one country are only allowed to attack only countries with which they share a common border. Upon conquest of that country, the armies may move into the newly conquered country.

During the course of play, a player often engages in a sequence of conquests with the goal of transferring a large mass of armies from some starting country to a destination country.
Typically, one chooses the intervening countries so as to minimize the total number of countries that need to be conquered. Given a description of the gameboard with 20 countries each with between 1 and 19 connections to other countries, your task is to write
a function that takes a starting country and a destination country and computes the minimum number of countries that must be conquered to reach the destination. You do not need to output the sequence of countries, just the number of countries to be conquered
including the destination. For example, if starting and destination countries are neighbors, then your program should return one.
The following connection diagram illustrates the sample input.



Input

Input to your program will consist of a series of country configuration test sets. Each test set will consist of a board description on lines 1 through 19. The representation avoids listing every national boundary twice by only listing the fact that country
I borders country J when I < J. Thus, the Ith line, where I is less than 20, contains an integer X indicating how many "higher-numbered" countries share borders with country I, then X distinct integers J greater than I and not exceeding 20, each describing
a boundary between countries I and J. Line 20 of the test set contains a single integer (1 <= N <= 100) indicating the number of country pairs that follow. The next N lines each contain exactly two integers (1 <= A,B <= 20; A!=B) indicating the starting and
ending countries for a possible conquest.
There can be multiple test sets in the input; your program should continue reading and processing until reaching the end of file. There will be at least one path between any two given
countries in every country configuration.

Output
For each input set, your program should print the following message "Test Set #T" where T is the number of the test set starting with 1. The next NT lines each will contain the result
for the corresponding test in the test set - that is, the minimum number of countries to conquer. The test result line should contain the start country code A the string " to " the destination country code B ; the string ": " and a single integer indicating
the minimum number of moves required to traverse from country A to country B in the test set. Following all result lines of each input set, your program should print a single blank line.

Sample Input
1 3

2 3 4

3 4 5 6

1 6

1 7

2 12 13

1 8

2 9 10

1 11

1 11

2 12 17

1 14

2 14 15

2 15 16

1 16

1 19

2 18 19

1 20

1 20

5

1 20

2 9

19 5

18 19

16 20

Sample Output
Test Set #1

1 to 20: 7

2 to 9: 5

19 to 5: 6

18 to 19: 2

16 to 20: 2

题意:

直接分析数据了~ 前19行是1~20点之间的联通关系,接下来一个数m 表示有m组s 、t 要求输出最短路径~

dijkstra:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#define mem(a, b) memset(a, (b), sizeof(a))
#define Wi(a) while(a--)
#define Si(a) scanf("%d", &a)
#define Pi(a) printf("%d\n", (a))
#define INF 0x3f3f3f3f
#include<algorithm>
using namespace std;
const int mx = 22;
int map[mx][mx];
int dis[mx], vis[mx];
int n;
int s, t;
void dijkstra(int s)
{
mem(vis, 0);  vis[s] = 1;
for(int i = 1; i <= 20; i++)	dis[i] = map[s][i];
dis[s] = 0;
int i, j, k;
for(i = 1; i < 20; i++)
{
int minn = INF;
for(j = 1; j <= 20; j++)
{
if(!vis[j] && minn > dis[j])
{
minn = dis[j];
k = j;
}
}
vis[k] = 1;
for(j = 1; j <= 20; j++)
{
if(!vis[j])  dis[j] = min(dis[j], dis[k]+map[k][j]);
}
}
}
int main()
{
int cas = 1;
while(Si(n)==1)
{
mem(map, 0x3f);
int a, b;
Wi(n){
Si(a);	map[1][a] = map[a][1] = 1;
}
for(int i = 2; i <= 19; i++){
Si(a);
Wi(a){
Si(b);	map[b][i] = map[i][b] = 1;
}
}
printf("Test Set #%d\n",cas++);
int m;  Si(m);
Wi(m){
scanf("%d%d", &s, &t);
dijkstra(s);
printf("%d to %d: %d\n", s, t, dis[t]);
}
printf("\n");
}
return 0;
}


floyd:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#define mem(a, b) memset(a, (b), sizeof(a))
#define Wi(a) while(a--)
#define Si(a) scanf("%d", &a)
#define Pi(a) printf("%d\n", (a))
#define INF 0x3f3f3f3f
#include<algorithm>
using namespace std;
const int mx = 22;
int map[mx][mx];
int dis[mx], vis[mx];
int n;

void floyd()
{
int i, j, k;
for(k = 1; k <= 20; k++){
for(i = 1; i <= 20; i++){
for(j = 1; j <= 20; j++)
map[i][j] = min(map[i][j], map[i][k]+map[k][j]);
}
}
}
int main(){
int cas = 1;
while(Si(n) == 1){
mem(map, 0x3f);
int a, b;
Wi(n){
Si(a); map[1][a] = map[a][1] = 1;
}
for(int i = 2; i < 20; i++){
Si(a);
Wi(a){
Si(b);   map[i][b] = map[b][i] = 1;
}
}
floyd();
printf("Test Set #%d\n",cas++);
int m;  Si(m);
int s, t;
Wi(m){
scanf("%d%d", &s, &t);
printf("%d to %d: %d\n", s, t, map[s][t]);
}
printf("\n");
}
return 0;
}


SPFA:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#define mem(a, b) memset(a, (b), sizeof(a))
#define Wi(a) while(a--)
#define Si(a) scanf("%d", &a)
#define Pi(a) printf("%d\n", (a))
#define INF 0x3f3f3f3f
#include<algorithm>
using namespace std;
const int mx = 22;
int dis[mx], vis[mx];
int n, edgenum;
int s, t;
int head[mx*100];
struct node{
int from, to, val, next;
};
node edge[mx*1000];
void init()
{
edgenum = 0;
mem(head, -1);
}
void add(int u, int v, int w)
{
node E = {u, v, w, head[u]};
edge[edgenum] = E;
head[u] = edgenum++;
}
void spfa(int s)
{
mem(vis, 0);  mem(dis, 0x3f);
queue<int> q;
vis[s] = 1;
dis[s] = 0;
q.push(s);
while(!q.empty()){
int u = q.front(); q.pop(); vis[u] = 0;
for(int i = head[u]; i != -1; i = edge[i].next){
int v = edge[i].to;
if(dis[v] > dis[u]+edge[i].val){
dis[v] = dis[u] + edge[i].val;
if(!vis[v]){
vis[v] = 1;
q.push(v);
}
}
}
}
printf("%d to %d: %d\n", s, t, dis[t]);
}
int main()
{
int cas = 1;
while(Si(n) == 1)
{
init();
int a, b;
Wi(n){
Si(a);
add(1, a, 1);
add(a, 1, 1);
}
for(int i = 2; i < 20; i++){
Si(a);
Wi(a){
Si(b);
add(i, b, 1);
add(b, i, 1);
}
}
printf("Test Set #%d\n",cas++);
int m;  Si(m);
Wi(m){
scanf("%d%d", &s, &t);
spfa(s);
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: