您的位置:首页 > 其它

hdu1150 2010.3.5

2016-02-05 15:06 274 查看
hdu1150 2010.3.5

Machine Schedule

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 1374 Accepted Submission(s): 654

Problem Description

As we all know, machine scheduling is avery classical problem in computer science and has been studied for a very longhistory. Scheduling problems differ widely in the nature of the constraintsthat must be satisfied and the type of schedule desired. Here
we consider a2-machine scheduling problem.

There are two machines A and B. Machine Ahas n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1,likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1.At the beginning they are both work at mode_0.

For k jobs given, each of them can beprocessed in either one of the two machines in particular mode. For example,job 0 can either be processed in machine A at mode_3 or in machine B at mode_4,job 1 can either be processed in machine A at mode_2 or in machine
B at mode_4,and so on. Thus, for job i, the constraint can be represent as a triple (i, x,y), which means it can be processed either in machine A at mode_x, or inmachine B at mode_y.

Obviously, to accomplish all the jobs, weneed to change the machine's working mode from time to time, but unfortunately,the machine's working mode can only be changed by restarting it manually. Bychanging the sequence of the jobs and assigning each job to
a suitable machine,please write a program to minimize the times of restarting machines.

Input

The input file for this program consists ofseveral configurations. The first line of one configuration contains threepositive integers: n, m (n, m < 100) and k (k < 1000). The following klines give the constrains of the k jobs, each line is a triple: i,
x, y.

The input will be terminated by a linecontaining a single zero.

Output

The output should be one integer per line,which means the minimal times of restarting machine.

Sample Input

5 5 10

0 1 1

1 1 2

2 1 3

3 1 4

4 2 1

5 2 2

6 2 3

7 2 4

8 3 3

9 4 3

0

Sample Output

3

Source

Asia 2002, Beijing(Mainland China)

Recommend

Ignatius.L

#include <stdio.h>
#include <string.h>

#define MAXN 100+10

int map[MAXN][MAXN];
int link[MAXN],f[MAXN];
int n,m,k;

int path(int t)
{
int i;
for(i=1;i<=m;i++)
{
if (f[i]==0&&map[t][i])
{
f[i]=1;
if(link[i]==-1||path(link[i]))
{
link[i]=t;
return 1;
}
}
}
return 0;
}

int EK()
{
int sum=0;
int i;
memset(link,-1,sizeof(link));
for(i=1;i<=n;i++)
{
memset(f,0,sizeof(f));
if(path(i)) sum++;
}
return sum;
}

int main()
{
while (scanf("%d",&n),n)
{
memset(map,0,sizeof(map));
scanf("%d %d",&m,&k);
int i,j,a,b;
for(i=1;i<=k;i++)
{
scanf("%d %d %d",&j,&a,&b);
map[a][b]=1;
}
printf("%d\n",EK());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: