您的位置:首页 > 其它

hdu1071 2010.3.5

2016-02-05 15:06 267 查看
hdu1071 2010.3.5

The area

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2175 Accepted Submission(s): 1401

Problem Description

Ignatius bought a land last week, but hedidn't know the area of the land because the land is enclosed by a parabola anda straight line. The picture below shows the area. Now given all theintersectant points shows in the picture, can you tell Ignatius the
area of theland?

Note: The point P1 in the picture is thevertex of the parabola.



Input

The input contains several test cases. Thefirst line of the input is a single integer T which is the number of testcases. T test cases follow.

Each test case contains three intersectantpoints which shows in the picture, they are given in the order of P1, P2, P3.Each point is described by two floating-point numbers X andY(0.0<=X,Y<=1000.0).

Output

For each test case, you should output thearea of the land, the result should be rounded to 2 decimal places.

Sample Input

2

5.000000 5.000000

0.000000 0.000000

10.000000 0.000000

10.000000 10.000000

1.000000 1.000000

14.000000 8.222222

Sample Output

33.33

40.69

Hint

For float may be not accurate enough,please use double instead of float.

Author

Ignatius.L

#include <stdio.h>
#include <math.h>

double x1,x2,x3,y11,y2,y3,k,b,a;
int i,t;

double fun(double x)
{
return (a*x*x*x/3)-(a*x1+k/2)*x*x+(a*x1*x1+y11-b)*x;
}

void main()
{
scanf("%d",&t);
for(i=1;i<=t;i++)
{
scanf("%lf %lf %lf %lf %lf %lf",&x1,&y11,&x2,&y2,&x3,&y3);
a=(y2-y11)/(x2-x1)/(x2-x1);
k=(y2-y3)/(x2-x3);
b=y2-k*x2;
printf("%.2lf\n",fun(x3)-fun(x2));
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: