您的位置:首页 > 其它

uvaoj-455:周期串

2016-02-02 20:33 344 查看
A character string is said to have periodk if it can be formed
by concatenating one or more repetitions of another string of lengthk. For example, the string "abcabcabcabc" has period
3, since it is formed by 4 repetitions of the string "abc". It also has periods 6 (two repetitions of "abcabc") and 12 (one repetition of "abcabcabcabc").

Write a program to read a character string and determine its smallest period.

Input

The first line oif the input file will contain a single integer N indicating how many test case that your program will test followed by a blank line. Each test case will contain a single character
string of up to 80 non-blank characters. Two consecutive input will separated by a blank line.

Output

An integer denoting the smallest period of the input string for each input. Two consecutive output are separated by a blank line.

Sample Input

1

HoHoHo


Sample Output

2


题意:简单的说就是求最小周期串的周期,因为数据量小,最多只有80,所以用枚举的方法,将每一个数据都判断一
次;


code:(仿照别的大神博客上的代码写得)

#include <cstdio>

#include <cstring>

int main()

{

int c;

char s[85];

scanf("%d",&c);

while(c--)

{

scanf("%s",s);//用gets不能过,可能是uva编译器不接受gets吧?

int len=strlen(s);

for(int i=1; i<=len; i++)

{

if(len%i==0)//判断len能否被i整除,只有整除才有成为周期的可能;

{

int j;

for(j=i; j<len ;j++)

{

if(s[j%i]!=s[j])//每次都是和第一个周期的字符做比较;

{

break;

}

}

if(j==len)

{

printf("%d\n",i);

break;

}

}

}

if(c) printf("\n");

}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: