您的位置:首页 > 其它

HDU 1013 Digital Roots 模拟//数学题

2016-02-02 16:06 375 查看
Problem Description:

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input

The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

Output

For each integer in the input, output its digital root on a separate line of the output.

Sample Input

24

39

0

Sample Output

6

3

题目的意思大概就是将各个数位的数字加起来,假如比10小,就输出这个数,假如比10大就继续这个操作。

典型的一道数学题。

假如你知道一个神奇的东西叫做数根的话,就可以随意秒杀了,不过直接模拟也可以过。

一个数的数根:b = ( a - 1) % 9 + 1(a为所有数位的数的累加和)

#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
#include<string>
using namespace std;
int main(){
char s1[1010];
while(scanf("%s",&s1)&&s1[0]!='0')
{
int len=strlen(s1);
int r=0;
for (int i=0;i<len;++i)
r+=s1[i]-'0';
printf("%d\n",(r-1)%9+1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: