您的位置:首页 > 其它

Poj 3461 Oulipo

2016-01-31 15:53 295 查看
Oulipo

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 31817Accepted: 12829
Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination,
l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program
that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T,
count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
***ERDXIVYERDIAN

Sample Output
1
3
0

Source

BAPC 2006 Qualification
思路:简单题目,KMP算法的简单应用,注意一下匹配到最后一个字符,也就是匹配成功之后不能退出循环,而应该将最后一个字符当成匹配失败,继续匹配【这里是参考他人的,还在弄懂为什么】

AC代码如下:

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;

const int maxn1=1000000+5;
const int maxn2=10000+5;
char aim[maxn1],tmp[maxn2];
int next[maxn2];

void getNext(int len){
    int j=-1,i=0;
    memset(next,0,sizeof(next));
    next[0]=-1;
    while(i<len){
        if(j==-1 || tmp[i]==tmp[j]){
            i++,j++;
            next[i]=j;
        }
        else j=next[j];
    }
}

void KMP(int len1,int len2){

    int ans=0;
    int j=0,i=0;
    while(i<len2){
        if(j==-1 || aim[i]==tmp[j]){
            i++,j++;
            if(j==len1){
                ans++;
                j=next[j];
            }
        }
        else j=next[j];
    }
    printf("%d\n",ans);

}

int main(){

    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%s",tmp);
        scanf("%s",aim);
        int len1=strlen(tmp);
        int len2=strlen(aim);
        getNext(len1);
        KMP(len1,len2);
    }

    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: