您的位置:首页 > Web前端

poj-1990-MooFest(树状数组)

2016-01-26 21:53 447 查看

Description

Every year, Farmer John’s N (1 <= N <= 20,000) cows attend “MooFest”,a social gathering of cows from around the world. MooFest involves a variety of events including haybale stacking, fence jumping, pin the tail on the farmer, and of course, mooing. When the cows all stand in line for a particular event, they moo so loudly that the roar is practically deafening. After participating in this event year after year, some of the cows have in fact lost a bit of their hearing.

Each cow i has an associated “hearing” threshold v(i) (in the range 1..20,000). If a cow moos to cow i, she must use a volume of at least v(i) times the distance between the two cows in order to be heard by cow i. If two cows i and j wish to converse, they must speak at a volume level equal to the distance between them times max(v(i),v(j)).

Suppose each of the N cows is standing in a straight line (each cow at some unique x coordinate in the range 1..20,000), and every pair of cows is carrying on a conversation using the smallest possible volume.

Compute the sum of all the volumes produced by all N(N-1)/2 pairs of mooing cows.

Input

Line 1: A single integer, N

Lines 2..N+1: Two integers: the volume threshold and x coordinate for a cow. Line 2 represents the first cow; line 3 represents the second cow; and so on. No two cows will stand at the same location.

Output

Line 1: A single line with a single integer that is the sum of all the volumes of the conversing cows.

Sample Input

4

3 1

2 5

2 6

4 3

Sample Output

57

线段树问题

首先将这n头牛按照v值从小到大排序。这样,排在后面的牛和排在前面的牛讲话,两两之间所用的音量必定为后面的牛的v值。然后,对于某头牛i来说,只要关心跟排在他前面的牛交流就好了。我们必须快速地求出排在他前面的牛和他之间距离的绝对值只和ans,只要快速地求出ans,就大功告成。这里需要两个树状数组。树状数组可以用来快速地求出某个区间内和,利用这个性质,我们可以快速地求出对于牛i,x位置比i小牛的个数,以及这个牛的位置之和。这里就需要两个树状数组,一个记录比x小的牛的个数a,一个记录比x小的牛的位置之和b,然后,我们可以快速地求出牛i和比牛i位置小的牛的所有距离的绝对值为:a*x[i]-b;也可以方便地求出比牛i位置大的牛到牛i的距离和,即 所有距离-b-(i-1-a)*x[i];那么此题就差不多了。

int会溢出,应该用long long

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define N 20005
using namespace std;
struct Cow
{
long long v, x;
friend bool operator < (Cow a, Cow b)
{
if (a.v != b.v) return a.v < b.v;
return a.x < b.x;
}
}cow
;
int n, ans[2]
;
void update(long long x, long long val, int d)
{
while (x <= 20000)
{
ans[d][x] += val;
x += x&-x;
}
}
long long sum(long long x, int d)
{
long long ret = 0;
while(x > 0)
{
ret += ans[d][x];
x -= x&-x;
}
return ret;
}
int main()
{
#ifndef ONLINE_JUDGE
freopen("1.txt", "r", stdin);
#endif
long long i, j, a, b;
long long ret = 0;
scanf("%d", &n);
for (i = 1; i <= n; i++)
{
scanf("%d%d", &cow[i].v, &cow[i].x);
}
sort(cow+1, cow+n+1);
memset(ans, 0, sizeof(ans));
for (i = 1; i <= n; i++)
{
a = sum(cow[i].x, 0);   //ÔÚiºÅÅ£×ó±ßµÄÅ£µÄÊýÄ¿
b = sum(cow[i].x, 1);   //ÔÚiºÅÅ£×ó±ßµÄËùÓÐÅ£µÄ×ø±êºÍ
ret += cow[i].v*(cow[i].x*a-b+sum(20000, 1)-b-(i-1-a)*cow[i].x);
update(cow[i].x, 1, 0);
update(cow[i].x, cow[i].x, 1);
}
printf("%lld\n", ret);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: