您的位置:首页 > 大数据 > 人工智能

1.3.2 Barn Repair

2016-01-25 02:17 447 查看
It was a dark and stormy night that ripped the roof and gates off the stalls that hold Farmer John's cows. Happily, many of the cows were on vacation, so the barn was not completely full.

The cows spend the night in stalls that are arranged adjacent to each other in a long line. Some stalls have cows in them; some do not. All stalls are the same width.

Farmer John must quickly erect new boards in front of the stalls, since the doors were lost. His new lumber supplier will supply him boards of any length he wishes, but the supplier can only deliver a small number of total boards. Farmer John wishes to minimize the total length of the boards he must purchase.

Given M (1 <= M <= 50), the maximum number of boards that can be purchased; S (1 <= S <= 200), the total number of stalls; C (1 <= C <= S) the number of cows in the stalls, and the C occupied stall numbers (1 <= stall_number <= S), calculate the minimum number of stalls that must be blocked in order to block all the stalls that have cows in them.

Print your answer as the total number of stalls blocked.

PROGRAM NAME: barn1

INPUT FORMAT

Line 1:

M, S, and C (space separated)

Lines 2-C+1:

Each line contains one integer, the number of an occupied stall.

SAMPLE INPUT (file barn1.in)

4 50 18

3

4

6

8

14

15

16

17

21

25

26

27

30

31

40

41

42

43

OUTPUT FORMAT

A single line with one integer that represents the total number of stalls blocked.

SAMPLE OUTPUT (file barn1.out)

25

[One minimum arrangement is one board covering stalls 3-8, one covering 14-21, one covering 25-31, and one covering 40-43.]

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
bool cmp(int a,int b)
{
return a>b;
}
int main()
{
freopen("barn1.in","r",stdin);
freopen("barn1.out","w",stdout);
int m,s,c;
cin>>m>>s>>c;
int cow[222],ans[222];
if(m>=c) cout<<c<<endl;//提供的木块比牛多
else{
for(int i=0;i<c;i++) cin>>cow[i];
sort(cow,cow+c);
for(int i=0;i<c-1;i++){
ans[i]=cow[i+1]-cow[i]-1;//每头牛之间的间隔
}
sort(ans,ans+c-1,cmp);
int tot=cow[c-1]-cow[0]+1;//头尾两头牛之间的间隔
for(int i=0;i<m-1;i++){//m块木块久减去间隔最大的m-1个
tot-=ans[i];
}
cout<<tot<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: