您的位置:首页 > 编程语言 > C语言/C++

1025. PAT Ranking (25)

2016-01-24 22:58 471 查看

一、题目

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your
job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and
then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4


二、代码

    只有一点需要注意,一开始用 long long 来表示 registration number,但最后一个 case 错误,后来换成 string 就行了。

#include <iostream>
#include <cstdio>
#include <vector>
#include <algorithm>

using namespace std;

struct Testee{
string ID;
int score;
int location;
int rankLocal;
int rankFinal;

Testee(string ID, int score, int location): ID(ID), score(score), location(location) {}
};

bool cmp(const Testee& lhs, const Testee& rhs){
return lhs.score > rhs.score
|| (lhs.score == rhs.score && lhs.ID < rhs.ID);
}

int main(){
int n;
scanf("%d", &n);

vector<Testee> total;
vector<Testee> ranklist;

for(int i = 0; i < n; ++i){
int k;
scanf("%d", &k);

for(int j = 0; j < k; ++j){
string id;
int score;

cin >> id;
scanf("%d", &score);
ranklist.emplace_back(id, score, i + 1);
}

sort(begin(ranklist), end(ranklist), cmp);

int sum = 0;
for(size_t i = 0; i < ranklist.size(); ++i){
++sum;
if(i == 0) ranklist[i].rankLocal = i + 1;
else{
if(ranklist[i].score == ranklist[i - 1].score){
ranklist[i].rankLocal = ranklist[i - 1].rankLocal;
}else{
ranklist[i].rankLocal = sum;
}
}

total.push_back(ranklist[i]);
}

ranklist.clear();
}

sort(begin(total), end(total), cmp);

int sum = 0;
for(size_t i = 0; i < total.size(); ++i){
++sum;
if(i == 0) total[i].rankFinal = i + 1;
else{
if(total[i].score == total[i - 1].score){
total[i].rankFinal = total[i - 1].rankFinal;
}else{
total[i].rankFinal = sum;
}
}
}

printf("%d\n", total.size());

for(size_t i = 0; i < total.size(); ++i){
cout << total[i].ID;
printf(" %d %d %d\n", total[i].rankFinal, total[i].location, total[i].rankLocal);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  C++ PAT 1025 PAT Ranking