您的位置:首页 > 编程语言 > C语言/C++

1015. Reversible Primes (20)

2016-02-19 14:17 344 查看
A reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

Sample Input:
73 10
23 2
23 10
-2

Sample Output:
Yes
Yes
No


#include <iostream>
#include <cstdio>
#include <cmath>

using namespace std;

bool isPrime(int n){
if(n <= 1) return false;

int nn = sqrt(n);
for(int i = 2; i <= nn; ++i){
if(n % i == 0) return false;
}

return true;
}

int reverse(int n, int radix){
int sum = 0;

do{
sum = sum * radix + n % radix;
n /= radix;
}while(n);

return sum;
}

int main(){
int n, d;

while(true){
scanf("%d", &n);
if(n < 0) break;
scanf("%d", &d);

if(isPrime(n) && isPrime(reverse(n, d))) printf("Yes\n");
else printf("No\n");
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  C++ PAT Reversible Primes