您的位置:首页 > 编程语言 > C语言/C++

1003. Emergency (25)

2016-02-18 09:50 337 查看
As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked
on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently
in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected
by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.

All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output
2 4


    采用DFS查找,查找过程记录下最短长度与在最短长度下的最大救援队数目,另外,DFS需要剪枝,不然运行会超时,即在已经得知一条路径的情况下,在深搜的过程中如果记录的当前路径长度大于已经记录的一条路径长度值,则停止深搜。

#include <iostream>
#include <cstdio>
#include <vector>
#include <limits>

using namespace std;

void dfs(int src, int dst, int dist, int& minDist, int teams, int& maxTeams, int& cnt, vector<bool>& used, vector<int>& weight, vector<vector<int>>& graph){
if(src == dst){
if(dist < minDist){
cnt = 1;
minDist = dist;
maxTeams = teams;
}else if(dist == minDist){
++cnt;
maxTeams = max(teams, maxTeams);
}

return;
}

if(dist > minDist) return; // Pruning

for(size_t i = 0; i < graph.size(); ++i){
if(!used[i] && graph[src][i] != numeric_limits<int>::max()){
used[i] = true;
dfs(i, dst, dist + graph[src][i], minDist, teams + weight[i], maxTeams, cnt, used, weight, graph);
used[i] = false;
}
}

}

int main(){
int n, m, c1, c2;
scanf("%d%d%d%d", &n, &m, &c1, &c2);

vector<vector<int>> graph(n, vector<int>(n, numeric_limits<int>::max()));
vector<int> weight(n);
vector<bool> used(n, false);

for(int i = 0; i < n; ++i){
scanf("%d", &weight[i]);
}

for(int i = 0; i < m; ++i){
int x, y, l;
scanf("%d%d%d", &x, &y, &l);
graph[x][y] = graph[y][x] = l;
}

int maxTeams = 0, count = 0, minDist = numeric_limits<int>::max();

dfs(c1, c2, 0, minDist, weight[c1], maxTeams, count, used, weight, graph);

printf("%d %d", count, maxTeams);

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  C++ PAT Emergency