您的位置:首页 > 其它

Gena's Code

2016-01-22 19:12 183 查看
Description

It's the year 4527 and the tanks game that we all know and love still exists. There also exists Great Gena's code, written in 2016. The problem this code solves is: given the number of tanks that go into the battle from
each country, find their product. If it is turns to be too large, then the servers might have not enough time to assign tanks into teams and the whole game will collapse!


There are exactly
n distinct countries in the world and the
i-th country added ai tanks to the game. As the developers of the game are perfectionists, the number of tanks from each country is beautiful. A
beautiful number, according to the developers, is such number that its decimal representation consists only of digits '1' and '0', moreover
it contains at most one digit '1'. However, due to complaints from players, some number of tanks of
one country was removed from the game, hence the number of tanks of this country may not remain beautiful.


Your task is to write the program that solves exactly the same problem in order to verify Gena's code correctness. Just in case.

Input

The first line of the input contains the number of countries
n (1 ≤ n ≤ 100 000). The second line contains
n non-negative integers
ai without leading zeroes — the number of tanks of the
i-th country.


It is guaranteed that the second line contains at least
n - 1 beautiful numbers and the total length of all these number's representations doesn't exceed
100 000.


Output

Print a single number without leading zeroes — the product of the number of tanks presented by each country.

Sample Input

Input
3
5 10 1


Output
50


Input
4
1 1 10 11


Output
110


Input
5
0 3 1 100 1


Output
0


Sample Output

Hint

In sample 1 numbers 10 and 1 are
beautiful, number 5 is not not.


In sample 2 number 11 is not
beautiful (contains two '1's), all others are
beautiful.


In sample 3 number 3 is not
beautiful, all others are beautiful.




题意:求一串数字的乘积。

思路:因为数据量比较大,肯定不能直接乘,又因为题目中说明最多只有一个不美丽的数字,就是说,其他数字都是1,10,100之类的,可以记录这些数字0的个数,在输出时直接在后面加0。注意,可以没有不美丽的数字。#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
char s[100005];
char s2[100005];
int main(){
int n,i,cnt,x,flag,len,j,cnt2,num,flag2;
while(scanf("%d",&n)!=EOF){
flag2=0;
flag=0;
num=0;
for(i=0;i<n;i++){
cnt=0;cnt2=0;
scanf("%s",s);
len=strlen(s);
if(s[0]=='0'){flag=1;}

for(j=0;j<len;j++){
if(s[j]!='0'){
if(s[j]!='1'){
strcpy(s2,s);cnt2=0;flag2=1;break;
}
else{
cnt++;
if(cnt>1){strcpy(s2,s);cnt2=0;flag2=1;break;}
}
}
else{
cnt2++;
}
}
num+=cnt2;
}
if(flag)printf("0\n");
else if(flag2){
printf("%s",s2);
while(num--)
printf("0");
printf("\n");
}
else{
printf("1");
while(num--)
printf("0");
printf("\n");
}
}
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm