您的位置:首页 > 产品设计 > UI/UE

hdu 1159 Common Subsequence 最大公共子串

2016-01-18 19:06 501 查看

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 30592    Accepted Submission(s): 13822


[align=left]Problem Description[/align]
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing
sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of
the maximum-length common subsequence of X and Y.

The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard
output the length of the maximum-length common subsequence from the beginning of a separate line.

 

[align=left]Sample Input[/align]

abcfbc abfcab
programming contest
abcd mnp

 

[align=left]Sample Output[/align]

4
2
0

 

[align=left]Source[/align]
Southeastern Europe 2003

题意:

求两个字符串的最大公共子串(不用连续)

LCS算法:可以看一下这个博客:http://blog.csdn.net/v_july_v/article/details/6695482





#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
char a[1005], b[1005];
int dp[1005][1005];
int main()
{
int i, j;
while(~scanf("%s%s",a, b))
{
int la = strlen(a);
int lb = strlen(b);
for(i = 0; i <= la ; i ++)
dp[i][0] = 0;// 第一列初始为0
for(j = 0; j <= lb ; j++)
dp[0][j] = 0;//第一行初始为0
for(i = 1; i <= la ; i ++)
{
for(j = 1; j <= lb ;j ++)
{
if(a[i - 1] == b[j - 1])
{
dp[i][j] = dp[i - 1][j - 1] + 1;
}
else
{
dp[i][j] = max(dp[i-1][j], dp[i][j-1]);
}
}
}
printf("%d\n", dp[la][lb]);

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: