您的位置:首页 > 编程语言 > PHP开发

【杭电oj】1093 - A+B for Input-Output Practice (V)

2016-01-13 20:46 543 查看

A+B for Input-Output Practice (V)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 64344    Accepted Submission(s): 42946


[align=left]Problem Description[/align]
Your task is to calculate the sum of some integers.

 

[align=left]Input[/align]
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

 

[align=left]Output[/align]
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

 

[align=left]Sample Input[/align]

2
4 1 2 3 4
5 1 2 3 4 5

 

[align=left]Sample Output[/align]

10
15

 

[align=left]Author[/align]
lcy

此题综合了两种多数据的处理方法。

代码如下:

#include <stdio.h>
int main()
{
int u;
int n;
int t,sum;
scanf ("%d",&u);
while (u--)
{
scanf ("%d",&n);
sum=0; //一定要记得初始化
while (n--)
{
scanf ("%d",&t);
sum+=t;
}
printf ("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: