您的位置:首页 > 编程语言 > C语言/C++

Sicily 1394. Root of the Problem

2016-01-07 13:59 363 查看
Time Limit: 1 secs, Memory Limit: 32 MB

Description

Given positive integers B and N, find an integer A such that AN is as close as possible to B. (The result A is an approximation to the Nth root of B.) Note that AN may be less than, equal to, or greater than B.

Input

The input consists of one or more pairs of values for B and N. Each pair appears on a single line, delimited by a single space. A line specifying the value zero for both B and N marks the end of the input. The value of B will be in the range 1 to 1,000,000 (inclusive), and the value of N will be in the range 1 to 9 (inclusive).

Output

For each pair B and N in the input, output A as defined above on a line by itself.

Sample Input

4 3

5 3

27 3

750 5

1000 5

2000 5

3000 5

1000000 5

0 0

Sample Output

1

2

3

4

4

4

5

16

(^__^) Just do it!

#include <iostream>
#include <cmath>

using namespace std;

int main()
{
int A, B, N;
while (cin >> B >> N && (B || N))
{
A = floor(pow(B, 1.0 / N));
A = (B - pow(A, N)) < (pow(A + 1, N) - B) ? A : A + 1;
cout << A << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  Sicily C++