您的位置:首页 > 编程语言 > C语言/C++

Sicily 1190. Reduced ID Numbers 简单哈希

2016-01-09 12:26 459 查看
Time Limit: 2 secs, Memory Limit: 32 MB

Description

T. Chur teaches various groups of students at university U. Every U-student has a unique Student Identification Number (SIN). A SIN s is an integer in the range 0 ≤ s ≤ MaxSIN with MaxSIN = 106-1. T. Chur finds this range of SINs too large for identification within her groups. For each group, she wants to find the smallest positive integer m, such that within the group all SINs reduced modulo m are unique.

Input

On the first line of the input is a single positive integer N, telling the number of test cases (groups) to follow. Each case starts with one line containing the integer G (1 ≤ G ≤ 300): the number of students in the group. The following G lines each contain one SIN. The SINs within a group are distinct, though not necessarily sorted.

Output

For each test case, output one line containing the smallest modulus m, such that all SINs reduced modulo m are distinct.

Sample Input

2

1

124866

3

124866

111111

987651

Sample Output

1

8

︿( ̄︶ ̄)︿ Just do it!

#include <iostream>
#include <cstring>

using namespace std;

int main()
{
int T, N, index, m, SIN[310];
bool HASH[99999];
cin >> T;
while (T--)
{
cin >> N;
for (int i = 1; i <= N; i++) {
cin >> SIN[i];
}
m = N;  // 起始值为N  \\Think about it!
index = 1;
while (index <= N)
{
// 不可设置为index < N  \\Think about it!
memset(HASH, false, sizeof(HASH));
for (index = 1; index <= N; index++)
if (!HASH[SIN[index] % m])
// 标记该位置已被占用
HASH[SIN[index] % m] = true;
else
// 证明有两个元素模值相同 => Fail
break;
m++;
}
cout << --m << endl;
}
return  0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  Sicily C++