您的位置:首页 > 编程语言 > C语言/C++

Sicily 1790. Single Round Match

2016-01-09 18:53 495 查看
Time Limit: 1 secs, Memory Limit: 32 MB

Description

Association for Couples Match (ACM) is a non-profit organization which is engaged in helping single people to find his/her other half. As November 11th is “Singles Day”, on this day, ACM invites a large group of singles to the party. People round together, chatting with others, and matching partners. There are N gentlemen and M ladies in the party, each gentleman should only match with a lady and vice versa. To memorize the Singles Day, ACM decides to divide people into 11 groups, each group should have the same amount of couples and no people are left without the groups. Can ACM achieve the goal?

Input

The first line of the input is a positive integer T. T is the number of test cases followed. Each test case contains two integer N and M (0<=N, M<=101000), which are the amount of gentlemen and ladies. It is worth notice that N and M are really huge. You are suggested to input the number with string.

Output

For each test case, output “YES” if it is possible to find a way, output “NO” if not.


Sample Input

3

1 1

11 11

22 11

Sample Output

NO

YES

NO

<( ̄ˇ ̄)/[/b] Just do it!

#include <iostream>
#include <string>

using namespace std;

int main()
{
string boy, girl;
int T, Temp;
cin >> T;
while (T--)
{
cin >> boy >> girl;
if (boy != girl) {
cout << "NO" << endl;
continue;
}

Temp = 0;
for (int i = boy.size() - 1; i >= 0; i--) {
Temp = Temp * 10 + boy[i] - 48;
Temp %= 11;
}
if (Temp == 0)
cout << "YES" << endl;
else
cout << "NO" << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  Sicily C++