您的位置:首页 > 其它

Talented Chef

2016-01-03 18:03 204 查看
Talented Chef
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld
& %llu
Submit Status

Description

As we all know, Coach Gao is a talented chef, because he is able to cook M dishes in the same time. Tonight he is going to have a hearty dinner with his girlfriend at his home. Of course, Coach Gao is going to cook all dishes
himself, in order to show off his genius cooking skill to his girlfriend.

To make full use of his genius in cooking, Coach Gao decides to prepare N dishes for the dinner. The i-th dish contains Ai steps. The steps of a dish should be finished sequentially. In each minute of
the cooking, Coach Gao can choose at most M different dishes and finish one step for each dish chosen.

Coach Gao wants to know the least time he needs to prepare the dinner.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains two integers N and M (1 <= N, M <= 40000). The second line contains N integers Ai (1 <= Ai <= 40000).

Output

For each test case, output the least time (in minute) to finish all dishes.

Sample Input

2
3 2
2 2 2
10 6
1 2 3 4 5 6 7 8 9 10


Sample Output

3
10


#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
int t,n,m,k;
scanf("%d",&t);
int maxn,sum,ans;
while(t--){
scanf("%d%d",&n,&m);
maxn=0;
sum=0;
ans=0;
for(int i=0;i<n;i++){
scanf("%d",&k);
sum+=k;
maxn=max(maxn,k);
}
if(sum%m) ans=sum/m+1;
else ans=sum/m;
ans=max(ans,maxn);
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  算法