您的位置:首页 > 其它

PAT甲级1001. A+B Format (20)

2016-01-01 21:40 573 查看

时间限制400 ms 内存限制65536 kB 代码长度限制16000 B 判题程序Standard作者CHEN, Yue Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).InputEach input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.OutputFor each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.Sample Input-1000000 9
Sample Output
-999,991


#include<stdio.h>
int main()
{
int  a,b,c;
scanf("%d%d",&a,&b);
c=a+b;
if(c>=1000000||c<=-1000000)
{
if(c>=0) printf("%d,%03d,%03d",c/1000000,(c%1000000)/1000,c%1000);
else printf("%d,%03d,%03d",c/1000000,-(c%1000000)/1000,-c%1000);
}
else if(c>=1000||c<=-1000){
if(c>=0) printf("%d,%03d",c/1000,c%1000);
else printf("%d,%03d",c/1000,-c%1000);
}
else
{
if(c>=0) printf("%d",c);
else printf("%d",c);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: