您的位置:首页 > 其它

Fuzhou oj--2221

2015-12-27 20:13 113 查看
Problem 2221 RunningMan

Accept: 7 Submit: 18

Time Limit: 1000 mSec Memory Limit : 32768 KB



Problem Description

ZB loves watching RunningMan! There's a game in RunningMan called 100 vs 100.

There are two teams, each of many people. There are 3 rounds of fighting, in each round the two teams send some people to fight. In each round, whichever team sends more people wins, and if the two teams send the same amount of people, RunningMan team wins.
Each person can be sent out to only one round. The team wins 2 rounds win the whole game. Note, the arrangement of the fighter in three rounds must be decided before the whole game starts.

We know that there are N people on the RunningMan team, and that there are M people on the opposite team. Now zb wants to know whether there exists an arrangement of people for the RunningMan team so that they can always win, no matter how the opposite team
arrange their people.



Input

The first line contains an integer T, meaning the number of the cases. 1 <= T <= 50.

For each test case, there's one line consists of two integers N and M. (1 <= N, M <= 10^9).



Output

For each test case, Output "Yes" if there exists an arrangement of people so that the RunningMan team can always win. "No" if there isn't such an arrangement. (Without the quotation marks.)



Sample Input

2100 100

200 100



Sample Output

No

Yes

解体思路:这是一道找规律题。最优情况是,当对立队为M人,其中一回合排出的人比Runniing man最少的人多一个时,接下来环节就再也派不出比Running man多的人了,此时求出的最小满足条件x,只要Running man队的人多于这个x就行了。

代码如下:

#include<stdio.h>
int main()
{
int cc;
scanf("%d",&cc);
while(cc--)
{
int  n,m;
int r;
scanf("%d%d",&n,&m);
if(m%2==0)
{
if(n>=3*(m/2)-1)
printf("Yes\n");
else
printf("No\n");
}
else
{
if(n>=3*(m/2))
printf("Yes\n");
else printf("No\n");

}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: