您的位置:首页 > 其它

FZOJ--2214--Knapsack problem(背包)

2015-12-27 20:09 267 查看
Problem 2214 Knapsack problem



Accept: 5    Submit: 8
Time Limit: 3000 mSec    Memory Limit : 32768 KB



Problem Description

Given a set of n items, each with a weight w[i] and a value v[i], determine a way to choose the items into a knapsack so that the total weight is less than or equal to a given limit B and the total value is as large as possible. Find the maximum total value.
(Note that each item can be only chosen once).



Input

The first line contains the integer T indicating to the number of test cases.

For each test case, the first line contains the integers n and B.

Following n lines provide the information of each item.

The i-th line contains the weight w[i] and the value v[i] of the i-th item respectively.

1 <= number of test cases <= 100

1 <= n <= 500

1 <= B, w[i] <= 1000000000

1 <= v[1]+v[2]+...+v
<= 5000

All the inputs are integers.



Output

For each test case, output the maximum value.



Sample Input

1
5 15
12 42 21 14 101 2



Sample Output

15



Source

第六届福建省大学生程序设计竞赛-重现赛(感谢承办方华侨大学)  

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f
struct node
{
int u,v;
}num[10010];
int dp[10010];
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int m,n;
scanf("%d%d",&n,&m);
memset(dp,INF,sizeof(dp));
int V=0;
for(int i=0;i<n;i++)
{
scanf("%d%d",&num[i].u,&num[i].v);
V+=num[i].v;
}
dp[0]=0;
for(int i=0;i<n;i++)
{
for(int j=V;j>=num[i].v;j--)
{
dp[j]=min(dp[j],dp[j-num[i].v]+num[i].u);
}
}
for(int j=V;j>=0;j--)
{
if(dp[j]<=m)
{
printf("%d\n",j);
break;
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: